[driverloader] Essid Cannot be set in Centrino

Martin Ebourne lists at ebourne.me.uk
Thu Nov 6 10:37:19 EST 2003

On Thu, 06 Nov 2003, Alvin Loh <alvinloh at alvinloh.com> wrote:
> However, I am unable to set the ESSID for the interface .. the rest of
> the options (nickname , keys etc.) are ok ..
> I have tried setting the key using iwconfig . .then setting the ESSID
> .. but it still doesn't work
> Anyone have the same problem ?

Yes, I have exactly the same problem. And from checking the archives here &
watching the list, inability to set the ESSID seems by far the most common
problem. As for you, WEP keys and all other settings appear to set
correctly, just ESSID cannot be set to anything - stays empty.

'iwconfig eth1 essid <value>' pauses for a couple of seconds while it
'appears' to work, but there are no log errors produced, and iwconfig after
lists the ESSID as blank. ipconfig is all set up correctly (static), but
naturally no connection is possible. I haven't tried blanking the ESSID on
the AP, nor setting 'any', which someone reported as working.

My setup is stock Fedora Core 1 (ie. test 3 fully updated). This is
kernel-2.4.22 with various patches Red Hat apply. The machine is Dell
Inspiron 500m, Centrino. The drivers I use are from the Dell website. I've
tried driverloader 1.23 and 1.24. Someone mentioned 1.25 but I've seen no
announcement on this list & hence didn't know about it to test it.

I use the 'source' binary rpm which builds the module itself. I have to fix
the makefile to include -DHAVE_FREE_NETDEV (or something like that) due to
patches in the kernel. Other than that everything except the ESSID goes like

I note that other cards have also been listed as having this problem, and
that some people have had the centrino work. I guess therefore it must be a
driver or kernel related problem.



More information about the driverloader mailing list