[driverloader] My wlan does not get an IP from DHCP

fmml at cedval.org fmml at cedval.org
Fri Jan 2 15:07:32 EST 2004


Not sure if this can help you but here is what I have done. I have
installed driverloader (Broadcom wireless adapter) on my laptop running
Suse 9 pro. After I ran the config, a new adapter was created "eth1".  I
used yast to configure the adapter with a static address(make sure DNS,
default gateway are setup properly) .  Now when I want to use my wireless
adapter, I run the following script (as a shortcut on my K desktop set to
run as the root user):

dldrconfig --info
ifconfig eth1 down # Found I had to bring down the interface before
# setting things
iwconfig eth1 mode managed
iwconfig eth1  key restricted s:99999999999999
iwconfig eth1  channel 9
iwconfig eth1 nickname "whoami5"
iwconfig eth1 rate 54M
iwconfig eth1 essid  alarm07
ifconfig eth1 up
/etc/init.d/network restart
# turning off eth0
ifconfig eth0 down

A little explanation:

I run the "dldrconfig --info" command as it forces the driverloader to be
up, found that between reboot it is sometimes off.

when running the iwconfig commands, alway make sure you setup the essid last.

I have an ethernet adapter on eth0, found that I had to turn it off for
the network routing to work properly.

Hope this help. Happy new year to all...


> Good Morning from Chicago!
> I have been trying to install a wireless network for a while under suse
> 9 pro, that I bought a few weeks ago. I'm having trouble getting my
> wireless card working. I had it working on madrake using madwifi
> drivers.
> In any case after trying madwifi (downloaded and the one that comes in
> the system), I never got and IP trough dhcp, nor I would be able to
> connect setting the parameters manually.   So, I've decided to try
> linuxant driverloader with the same success rate,  everything works card
> gets recognize, I can " iwlist wlan0 scan " and check my environment,
> iwconfig shows my card properly connected, and ifconfig shows my card,
> but without IP address:
> wlan0     Link encap:Ethernet  HWaddr 00:0C:41:AD:D3:21
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:7 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
> this is my ifcfg_wlan0:
> BOOTPROTO='static'
> MTU=''
> STARTMODE='onboot'
> I also tried setting the mode as Managed, same result.
> I read somewhere that ISC dhclient worked better that dhcpcd, so I did
> try changing them, if exactly the same result.
> I also went out and bought a different card with a different chipset
> supported by linuxant driveloader,  and to my dismay I got to the same
> point.
> I think that this is something related to suse...but I don't know where
> to look of how to troubleshoot the problem any further.
> Any suggestions, advise, etc   will be more than welcome.
> Roberto
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list