[driverloader] Centrino WIFI on Amilo M7400

Francis Irving francis at flourish.org
Thu Jan 15 14:53:14 EST 2004


I'm trying to get WIFI working on a Fujitsu-Siemens Amilo M7400 laptop.
It doesn't work, and here are the details.

I'm using Linux kernel 2.4.22, with Debian testing.  Dual boot to
Windows XP and everything works fine - it scans and finds the network
from my router.  The wireless router is configured with no security.

The driver loads apparently fine:

# dldrconfig --info
Linuxant DriverLoader for Wireless LAN devices, version 1.54

Web configurator: listening on

Current parameters: ("dldrconfig --info")

Wireless interface name: eth1
        MAC address    : 00:04:23:74:E0:30
        Device instance: PCI-0000:02:06.0-8086:1043-8086:2527
        Device driver  : w70n51
        Description    : Intel(R) PRO/Wireless 7100 LAN Card Driver
        Adapter model  : PRO/Wireless LAN 2100 3B Mini PCI Adapter
        License owner  : francis at flourish.org
        License key    : 2C-7D-AB-65-FA-29
        License status : OK (Expires 2004-02-13)

I've tried with two versions of the Windows driver w70n51:
07/31/2003, (latest intel driver)
03/07/2003, (version currently installed when I reboot to Windows)

The wireless ethernet interface appears OK:

# iwconfig eth1
eth1      IEEE 802.11-DS  ESSID:""  Nickname:"unknown"
          Mode:Managed  Channel:0  Bit Rate=11Mb/s
          RTS thr=1600 B   Fragment thr=0 B
          Encryption key:off
          Power Management:off
          Link Quality:1/1  Signal level:-98 dBm  Noise level:-200 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

At this point things stop working.  If I scan for wireless connections,
it doesn't find any.  Can you explain what exactly this message means -
does it mean iwlist failed to even connect to the hardware and scan,
or does it mean that it tried scanning but couldn't find anything?

# iwlist eth1 scan
eth1      Failed to read scan data : No data available

I tried configuring the eth1 channel and ESSID and doing "ifup eth1", but the
pump DHCP client never gets a reply to its requests.

In the BIOS I changed a setting to "Enable WIFI".  This now means that under
Windows I don't have to press the Wifi button to turn on the connection - 
the wifi LED on the laptop lights up as soon as Windows boots.  Under
Linux it makes no difference.

Also, under Linux the wifi LED on the laptop has never lit up.  I feel as 
though the driver isn't initialising right - that the light should light up
when the wifi hardware is powered, before a connection is made.

Anyone have any suggestions?  I'm desperate to pay my $20 as soon as this works ;)


More information about the driverloader mailing list