[driverloader] Problems with Dell TruMobile Broadcom Wireless

burgeke at HQ.VerizonWireless.com burgeke at HQ.VerizonWireless.com
Wed Feb 18 14:03:19 EST 2004

JDS is based off of SLED 1.0. I am not sure if the driverloader SuSE
packages will work for you or not but I <believe> the key is that the
interface is expected to be wlan0 as opposed to eth0. Check out the FAQ
bullet #5 http://www.linuxant.com/driverloader/wlan/faq.php 

You should setup the interface via YAST (or the equivilent Sun branded util
in JDS) and then edit the appropriate file in /etc/sysconfig/network/wlan0?
to reflect STARTMODE="onboot" instead of "manual".

I had a heck of a time setting it up initially under JDS but it does work.
You might try posting to the JDS forums as well as this one, I believe I
recall seeing a thread about it there. Oh wait, I see you already posted
there ...


-----Original Message-----
From: Jay Davidson [mailto:jaysdavidson at yahoo.com] 
Sent: Wednesday, February 18, 2004 12:02 PM
To: Driver Loader Forum List
Subject: [driverloader] Problems with Dell TruMobile Broadcom Wireless

> I have a fairly new (6-9 months) Dell Latitude D600
with a
> Broadcom
> TruMobile dual band.  I just installed Sun Java Desktop System over 
> the weekend.  I am running a dual boot JDS-Linux/Windows 2000.
> I am having trouble getting my Dell TruMobile Broadcom Wireless card 
> to function correctly under linux.  It functions properly when running 
> Windows 2000.
> I have downloaded and installed the compatible driver and app from 
> www.linuxant.com.
> 3 Problems:
> 1. After rebooting, the dldrconfig app that is used load the device 
> driver does not load and so the wireless device is not activated until 
> I open a terminal and load it again. How can I get this to load on 
> boot? I also must set, via iwconfig, all of the wireless settings 
> again (ESSID, channel, mode (Managed), etc).  How do I get these to 
> stay intact?
> 2. I have a DLink router, WEP disabled, channel 6 -- very simplistic 
> setup. But, I am unable to get the wireless card to communicate to the 
> access point.
> When
> I run iwconfig and set the parameters, it is picking up the MAC 
> address of the access point correctly.
> And
> the wireless monitor is activated and appears to be working. Is there 
> another setting that I'm missing?
> eth1 IEEE 802.11g ESSID:"JSDWireless"
> Nickname:"unknown"
> Mode:Managed Frequency:2.437GHz Access Point:
> 00:0D:88:89:3F:3D
> Bit Rate=54Mb/s
> RTS thr:off Fragment thr:off
> Encryption key:off
> Power Management:off
> Link Quality:1/1 Signal level:-42 dBm Noise
> level:-86
> dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive 
> retries:0 Invalid misc:0 Missed beacon:0
> 3.  I see from dmesg the following message:
> "ACPI-0207: *** Warning:  Buffer created with zero length in AML
>      -0091: *** ut_allocate: Attemp to allocate zero bytes
> I've tried dldrconfig --info, and everything seems to be in order.  No 
> errors are generated and all the information listed is correct.

driverloader mailing list
driverloader at lists.linuxant.com

More information about the driverloader mailing list