[driverloader] Problems Proxim B/G Silver on Suse 9.0

Bill Bradley wbradley at bham.rr.com
Fri Feb 20 17:03:14 EST 2004

Hello All,

I have been using driverloader for several months now with my Proxim (Orinoco) 
B/G Silver pcmcia card.  It has worked great under RedHat, Fedora, Debian, 
and Mandrake.  However I am having major problems with Suse 9.0.

Suse keeps loading the madwifi drivers.  Apparently it comes with 9.0.  I can 
rmmod the ath_hal, ath_pci, wlan module , do a dldrconfig --info and cause 
the card to be reported as:

Wireless interface name: wlan0 (format "wlan%d")
        MAC address    : 00:20:A6:4C:A3:F1
        Device instance: PCI-0000:03:00.0-168c:0013-14b7:0a40
        Device driver  : ntpr11ag
        Description    : ORiNOCO 802.11bg ComboCard Gold
        License owner  : williammbradley at msn.com
        License key    : <left blank>
        License status : OK

OK its reporting as wlan0, which seems wierd since every other distro I have 
used it with gives it as eth1...but whatever...

However now I cant get a DHCP addresss on the interface with the driverloader 
module.  Yes I have a ifcfg-wlan0 in my /etc/sysconfig/network dir.  It was 
empty (even though I configed it with YAST to be dhcp) so I edited it 
manually.  Here's what it looks like:


I also have a line in modules.conf.local that aliases wlan0 to the 
driverloader module like so :

alias wlan0 driverloader

I can use iwlist to scan AP, rates, etc.  I just can't get a dhcp addy.  I 
just want it to work like it has with other distro's....slap the card in and 
its up and running.  I don't have a lot of SuSE exp. so I dont know where I 
could be going wrong.

Hopefully someone on this list or in LinuxAnt tech support can help?

Bill Bradley

More information about the driverloader mailing list