[driverloader] Coda: success with D-Link DWL 520 & Mandrake 9.2

William Irving MacGregor macgregor at austin.rr.com
Thu Mar 25 08:58:35 EST 2004

Two days ago, I reported that all was working except autostart on boot. 
  Linuxant support came through again--they informed me that 
"MII_NOT_SUPPORTED=yes" was missing from my ifcfg-eth1 file.  I added 
this line, and now the wireless link comes up on every boot, during the 
init sequence (no more "FAILED" flag!).

Today, Driverloader is an unqualified success, working just as I expect 
it to.

Just FYI, I note two issues with Mandrake 9.2 that impact wireless 

1) If I open the Network screen in Mandrake Control Center, and allow 
MCC to automatically [mis-] configure eth1, it will overwrite the 
ifcfg-eth1 file with a minimal Ethernet controller template.  I've 
stubbed my toe on this a couple of times now, so I keep a backup of the 
known good file in /etc/sysconfig/network-scripts/ifcfg-eth1~ and cp it 
over ifcfg-eth1 to recover quickly.

2) If I turn on drakFirewall (aka shorewall), web browser connectivity 
is lost (DNS doesn't resolve, and I suspect no IP traffic is flowing, 
although ifconfig reports the wireless link is still active).  Don't 
know the cause yet, but it may be a similar sort of mismatch between 
GUI and firewall rules file.

Happy customer signing off for now,

   - Bill

William I. MacGregor      ...Identification & Credentialing Solutions
Ph.D., CISSP                      ...Information Security Strategy
+1 512 775 4095                 ...Security Industry Business 
macgregor at austin.rr.com   ...IT Trends & Futures

More information about the driverloader mailing list