[driverloader] WEP does not work on my Intel 2200BG

KBB0927 at cs.com KBB0927 at cs.com
Mon Apr 5 13:28:47 EDT 2004

Yes, I have the exact same experience. Intel Pro/Wireless 2200 BG only
works without WEP. I have an ASUS M3N notebook and the WEP _will_ work 
with a pcmcia Broadcom based cared:  Buffalo AirStation (WLI-CB-G54A) 
flawlessly. So I know WEP works under SuSE 9.0, just not with Intel
Pro/Wireless 2200BG


"Stefan Bröcheler" <sbr2 at gmx.de> wrote:

>I use driverloader 1.6.4 successfully on my sony Z1 notbook with  Intel
>Pro/Wireless 2200BG   WLAN under SuSE 9.0. However it only works *without* WEP
>encryption. I would be very happy if you could help me to get WEP up and
>Whenever I set the WEP key via iwconfig, e.g.
>iwconfig wlan0 essid broecheler.de channel 6 mode Managed rate 11M key
>then I find error events in /var/log/warn
>Apr  5 17:28:23 linux kernel: driverloader: ndisSetInformation:
>802_11_ADD_KEY st=FAILURE W=0 N=0
>Apr  5 17:28:23 linux kernel: wlan0: Error -5 configuring keys
>Apr  5 17:28:25 linux kernel: driverloader:
>ndisWrapCheckForHangTimerFunc_stk: PCI-0000:02:0b.0-8086:4220-8086:2753 hung, resetting
>Apr  5 17:28:25 linux kernel: driverloader: ndisSetInformation:
>802_11_ADD_KEY st=FAILURE W=0 N=0
>Apr  5 17:28:25 linux kernel: wlan0: Error -5 configuring keys
>Apr  5 17:28:36 linux kernel: dldr_thread: 2455 stack overflow
>According to this, the configuration of the key does not work in the Windows
>driver. On the other hand when I look at interface config via iwconfig, the
>key is there:
>wlan0     IEEE 802.11-DS  ESSID:"broecheler.de"  Nickname:"unknown"
>          Mode:Managed  Bit Rate=54Mb/s
>          RTS thr=1600 B   Fragment thr=2304 B
>          Encryption key:0123-4567-89
>          Power Management:off
>          Link Quality:0  Signal level:0  Noise level:0
>          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>Nevertheless the DHCP client can not obtain an adress (without encryption it
>I have tried this with original drivers that where installed on the
>w22n51  Intel   11/26/2003,
>as well as a newer version that I found on the web:
>w22n51  Intel   01/02/2004,
>Both do not work. 
>Any idea?
>Thanks for your help
>driverloader mailing list
>driverloader at lists.linuxant.com

More information about the driverloader mailing list