[driverloader] Unable to get wireless working after upgrade.

KBB0927 at cs.com KBB0927 at cs.com
Wed Apr 14 11:42:37 EDT 2004

I dunno if this will help or not, but try dldrconfig -kernel to see if it
will compile against the kernel in the beta. I had no trouble with broadcom
drivers under SuSE 9.0. If that helps, try dldrconfig -netdevname=wlan%d to
make it use wlan0 as the net device and then you should be able to see it
in yast or at least configure it. HTH.


Brian Utterback <brian.utterback at sun.com> wrote:

>I have a Fujitsu Lifebook N3010, with a built-in Broadcom wireless 54g interface.
>The OS I am using is Java Desktop System, which is repackaged SuSe 8.1 SLEC 1.0.
>This is using kernel 2.4.19-4GB.
>In December, I installed the then latest driverloader and used the WinXP
>drivers linked off of the linuxant site as the drivers. After some futzing
>with the configuration, I was able to connect with my wireless network if I
>ran "ifdown eth0" and "ifup eth1", but not at bootup. Since it was working,
>I paid the license fee.
>I lately re-installed the OS, this time with a beta copy of the next release
>of the Java Desktop System, still based on SuSe 8.1 SLEC 1.0, still with
>kernel 2.4.19-4GB.  I installed the latest driverloader and the broadcom
>drivers as before. Before I re-installed, I copied the entire /etc directory
>to CDROM for reference.
>After the upgrade, I am totally unable to access the wireless network. I can
>see the interface with ifconfig, and "iwlist scan" appears to see the access
>point, but "netstat -i" shows only TxErrors and no received packets at all.
>If I do "ifup eth1", it says that DHCP is starting, but that it is unable
>to get an IP address and that it will continue in the background. The
>logs on the access point never show a new system connected, nor do the
>stats show any received packets.
>I have tried every configuration option I can think of. I tried using the
>ifcfg-eth1 and ifcfg-eth0 files from the previous OS. I tried configuring
>with yast2. I tried mixing and matching these. I tried completely turning
>off all access controls and keys in the access point, running a completely
>open network, all to no avail.
>I am at my wits end. Can anybody help me or provide any pointers? If it is any
>help I have a slightly redacted version of dirverloaderdiag at:
>It is bafflingly paradoxical that the United States is by far the world's
>leading scientific nation while simultaneously housing the most scientifically
>illiterate populace outside the Third World. - Richard Dawkins
>Brian Utterback - OP/N1 Revenue Product Engineering, Sun Microsystems, Inc.
>Ph/VM: 781-442-1343, Em:brian.utterback-at-ess-you-enn-dot-kom
>driverloader mailing list
>driverloader at lists.linuxant.com

More information about the driverloader mailing list