[driverloader] eth0 disabled after start up (Suse 9, DWL-G650+)

Dennis Bruno dennis.bruno at comcast.net
Wed Apr 14 21:01:54 EDT 2004

I have had the same problem for several months now also, although both the 
card and kernel version are different.  I run a Linksys WPC54g card with 
kernel 2.4.22-1.2174 (Fedora Core 1).  I first began seeing the problem when 
I moved to FC 1 from RH9.  I've been living with a workaround.  It seems that 
the trick is to get driverloader to reinitialize (I either eject and insert 
the card also, or issue: cardctl suspend/cardctl resume).  When I first 
experienced the problem, I sent all of the dldrdiag info to the Linuxant 
folks, and they pointed me in the direction of the kernel.  I suspect it's 
something with card services and timing.  I run on a very old Gateway Solo 

I'm pretty much out of ideas, so any suggestions would be appreciated.

Dennis Bruno

On Tuesday 13 April 2004 05:32 am, Jochen Staerk wrote:
> Hi,
> Driverloader is great, except I have to eject and re-insert my D-Link
> DWL-G650+ whenever I booted or re-booted my laptop.
> Symtoms are as follows: after booting (see
> for my dmesg-log and
> for the output of my lsmod-command)
> ifconfig will not show eth0 ( as you
> can see I have vmWare installed) and iwconfig
> ( will contain a wireless card, but
> no connection. dmesg says it's disconnected. The "Act"-LED does not
> blink, but the "Link"-LED is on.
> When I eject and insert the card again, I'll see the following dmesg
> ( and lsmod
> ( As you can see, there is now
> a "eth0: New link status: Connected (0001)", the brigde actually starts
> and Act blinks when data is transferred.
> I've been having this for some months, so I know it's not limited to my
> current 2.4.21-199-default kernel but the 2.4.21s that I used before
> upgrading to this kernel are affected as well.
> Does anybody have an idea or a similar problem?

More information about the driverloader mailing list