[driverloader] 2.6.5-mm5 series

Aaron Rusnak aaronrusnak at comcast.net
Fri Apr 16 01:51:01 EDT 2004

I have driverloader working perfectly for the 2.6.5-mm1 kernel in gentoo, but 
when I upgrade to 2.6.5-mm5 kernel, driverloader won't compile. "dldrconfig" 
just gives me an error message, and says to look 
in /tmp/dldrconfig-buildlog.txt. So I do, and here's what it says.

rm -f *.o GPL/*.o *.ko GPL/*.ko *.mod.c GPL/*.mod.c .*.cmd 
GPL/.*.cmd  /lib/modules/2.6.5-mm5/build/.tmp_versions/driverloader.mod
(cd /lib/modules/2.6.5-mm5/build && make 
"SUBDIRS+=/usr/lib/driverloader/modules" modules)
make[1]: Entering directory `/usr/src/linux-2.6.5-mm5'
Makefile:954: target `/usr/lib/driverloader/modules' given more than once in 
the same rule.
Makefile:970: warning: overriding commands for target 
Makefile:955: warning: ignoring old commands for target 
  Building modules, stage 2.
head: error reading `/usr/lib/driverloader/modules': Is a directory
make[1]: Leaving directory `/usr/src/linux-2.6.5-mm5'
rm -f "/lib/modules/2.6.5-mm5/misc/driverloader"*.ko
install -m 644 driverloader.ko /lib/modules/2.6.5-mm5/misc
install: cannot stat `driverloader.ko': No such file or directory
make: *** [minstall] Error 1

Does the actual dldrconfig script need to be modified? I'm pretty lost here, 
but would like to be able to keep using the -mm series kernels. If you need 
any more info, please ask. 

Aaron Rusnak
email: aaronrusnak at comcast.net

More information about the driverloader mailing list