[driverloader] Trouble starting Netgear WG511 w/ driver v2.1.0 and DriverLoader 1.65

Martin Thorpe driverloader at met24.org
Thu Apr 22 18:30:52 EDT 2004

Hi all,

I'm trying to get my Netgear WG511 Cardbus adapter to run with
DriverLoader 1.65 and Netgear's v2.1.0 driver so that I can use WPA.
Unfortunately I'm not having much luck! I can get the card to work nicely
with the 1.6 driver, but that driver doesn't support WPA.

When I upload the v2.1.0 driver through the web interface, I'm asked for
the .inf file as usual, and then it asks me for a .sys and a .arm file.
This particular driver version uses the new format firmware that's
embedded in the .sys file itself, rather than being a separate file as was
the case for the 1.6 driver. Supplying the .arm file from the older driver
doesn't help, not that I was expecting it to ;-)

I've got an SMC 2802W v2 PCI card as well, which also uses the new format
firmware that's embedded in the driver. Interestingly, the upload process
for that card's driver only asks for the .sys file. The driver works very
nicely in DriverLoader, and WPA works a treat too.

I've tried fiddling with the v2.1.0 .inf file to remove all references to
.arm files, but that didn't help. When I tried installing the driver in
WinXP, it didn't try to look for a .arm file, and the card worked fine, so
it obviously doesn't need it!

Output from `dldrconfig --dump` is available if required.

Thanks in advance.

All the best,


More information about the driverloader mailing list