[driverloader] Unable to associate, using Intel 2200BG

Byron Darrah bdarrah at pacbell.net
Wed Jun 2 04:26:46 EDT 2004


driverloader seems to find the device just fine, and defines it as

However, when trying to set the access point, I get an error, and I
hope someone can help.

wpa_supplicant says it's trying to associate with my AP, and prints
the correct BSSID, SSID, and frequency.  Then it outputs:

 ioctl[SIOCSIWAP]: Input/output error

And this shows up in syslog:

  driverloader: ndisSetInformation: 802_11_BSSID st=FAILURE W=0 N=0

I also get a similar error when attempting iwconfig eth1 ap <mac

   SET failed on device eth1 ; Input/output error.

(If I turn off the encryption security at the AP, I still get the
same error).

I'm using:
   generic kernel 2.4.25 with wireless extensions enabled.
   WAP: Dell TrueMobile 2300.
   chipset: Intel 2200BG
   driverloader 1.71
   libdnet 1.8
   libpcap 0.8.3
   wireless tools 26
   ndis driver: w22n51.sys for Windows XP

I really hope this looks familiar to someone.


More information about the driverloader mailing list