[driverloader] Dlink DWL-510 cannot find accesspoint

Linuxant support (Jonathan) support at linuxant.com
Sat Jun 5 13:32:21 EDT 2004


please try with different versions of the Windows XP driver to see if there is 
a difference.

For the 8180L Realtek Windows XP driver, it is quite possible that you will 
have to edit the .INF file before you upload it with the Web Configurator. 
You will have to change one of the PCI ID listed in the .INF file to match 
the PCI ID of you wireless card. You can obtain the PCI ID (including the sub 
PCI ID) of your wireless card with the 'lspci -vvvn' command in a root shell.

If you require more assistance, please send at support at linuxant.com the output 
of 'dumpdiag'. Type the following in a root shell:

dldrconfig --dumpdiag

Just send us the generated file located in /tmp ('driverloaderdiag.txt').
It'll help us solve the problem.


Technical specialist / Linuxant
support at linuxant.com

On Saturday 05 June 2004 11:23, Johan Andrén wrote:
> I recently bought a DWL-510 in the belief that dlink made good stuff and
> perhaps even supported linux. Quite a mistake. Anyways, I decided to
> give driverloader a try rather than leaving the card back to the store.
> I have downloaded the most recent drivers from dlinks homepage, and
> everything seems to work with driverloader (1.71). I use linux 2.6.6.
> When I run iwconfig it shows the card and all properties can be set.
> This is where the trouble does begin.
> After running ifconfig up on the interface (which seems to work) i run
> dhcpcd to get an IP-address, at this point nothing happens, dhcpcd bails
> without even giving an error message, but in the systemlog i get this:
> eth1: WEP128, WEP64 supported
> eth1: D-Link Air Wireless LAN Adapter at 0000:00:0b.0 (MAC address
> 00:40:05:3F:27:2E) ready
> eth1: New link status: Disconnected (0002)
> driverloader: NdisScheduleWorkItem: work full, increase
> When i run "iwlist scan" it tells me the following:
> "eth1      Failed to read scan data : No data available"
> I have read through the FAQ thoroughtly without finding anything. I also
> searched a bit on the net and someone adviced to use realtek
> 8180L-drivers from their homepage. I have tried that but with that
> drivers the card is not recognized at all.
> The accesspoint is a dlink 614+ which does work with other wlan-cards in
> the network.
> Any help appreciated.

More information about the driverloader mailing list