[driverloader] Dlink DWL-510 cannot find accesspoint

Johan Andrén johan at evelyngrace.net
Sun Jun 6 11:40:52 EDT 2004

Okay, I have a solution. Thought I'd share it with everyone else.

I downloaded the latest windows XP driver for RTL8180l from the realtek
homepage. I then replaced all "VEN_10EC" with "VEN_1186" (the hardware
vendor), all "DEV_8180" with "DEV_3300" and finally all
"SUBSYS_818010EC" with "SUBSYS_3301" and now it finds the accesspoint
with "iwlist scan" and "iwlist ap".

On lör, 2004-06-05 at 17:23 +0200, Johan Andrén wrote:
> I recently bought a DWL-510 in the belief that dlink made good stuff and
> perhaps even supported linux. Quite a mistake. Anyways, I decided to
> give driverloader a try rather than leaving the card back to the store.
> I have downloaded the most recent drivers from dlinks homepage, and
> everything seems to work with driverloader (1.71). I use linux 2.6.6.
> When I run iwconfig it shows the card and all properties can be set.
> This is where the trouble does begin.
> After running ifconfig up on the interface (which seems to work) i run
> dhcpcd to get an IP-address, at this point nothing happens, dhcpcd bails
> without even giving an error message, but in the systemlog i get this:
> eth1: WEP128, WEP64 supported
> eth1: D-Link Air Wireless LAN Adapter at 0000:00:0b.0 (MAC address
> 00:40:05:3F:27:2E) ready
> eth1: New link status: Disconnected (0002)
> driverloader: NdisScheduleWorkItem: work full, increase
> When i run "iwlist scan" it tells me the following:
> "eth1      Failed to read scan data : No data available"
> I have read through the FAQ thoroughtly without finding anything. I also
> searched a bit on the net and someone adviced to use realtek
> 8180L-drivers from their homepage. I have tried that but with that
> drivers the card is not recognized at all.
> The accesspoint is a dlink 614+ which does work with other wlan-cards in
> the network.
> Any help appreciated.

More information about the driverloader mailing list