[driverloader] problems getting wlan in my Thinkpad T42p running (AR5212 chip)

Linuxant support (Jonathan) support at linuxant.com
Tue Sep 14 12:41:32 EDT 2004


you could try with different versions of the Windows XP driver to see if 
there is a difference. You could also try to recompile your kernel 
without the CONFIG_PREEMPT option.

If you recompile your kernel, please also recompile the DriverLoader 
module with the 'dldrconfig --kernel' command in a root shell.

Since you have problems with many solutions to use your wireless card 
under Linux, did you tried the wireless card under Windows XP to see if 
it works?


Technical specialist / Linuxant
support at linuxant.com

Joern Heissler wrote:
> Hi,
> I'm trying to get my AR5212 chip in my Thinkpad T42p working.
> I tried three different ways:
> - madwifi driver: works, but has packet loss ~ 50%
> - ndiswrapper: sometimes `iwlist scan' finds my ap, but that not
>   everytime. I can't connect to my wlan at all.
> - driverloader: sometimes works for some seconds (last evening some
>   minutes). The connection was much better than with madwifi.
> With driverloader I get this kernel message:
> NETDEV WATCHDOCH: eth1: transmit timed out
> see also:
> http://wulf.eu.org/stuff/driverloaderdiag.txt
> Hope you can help me, tia!
> Joern Heissler
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list