[driverloader] problems getting wlan in my Thinkpad T42p running (AR5212 chip)

daltrey basdlin at fastbk.com
Tue Sep 14 16:23:11 EDT 2004

I just blunder around doing things by trial and error.  I am using the 
driverloader with a broadcom lan card, SuSE Linux with the latest build. 
(The .104 build would not work for me.)

Here are my thoughts, since this is what I discovered on my computer. 
My ethernet card is "eth0."  My wireless card is "wlan0".

My wireless card will not work when the ethernet card is active.
My wireless card will not pick up adequate DHCP info at boot.

My solution is the following:  I wrote a script and put a link on my 
desktop.  I run it in a "superuser" terminal.  It has the following 

ifdown eth0
ifdown wlan0
ifup wlan0

Sometimes I have to run it twice.  My broadcom card is now working very 
well, and will continue running even when I log in and out, provided I 
don't shutdown linux.

The script "turns off" the ethernet card, turns off the wireless card 
and then turns the wireless card back on. "ifup wlan0" causes a DHCP 
request for the wireless and from that point it works.

Hope this information will help someone.


Joern Heissler wrote:

> Hi,
> I'm trying to get my AR5212 chip in my Thinkpad T42p working.
> I tried three different ways:
> - madwifi driver: works, but has packet loss ~ 50%
> - ndiswrapper: sometimes `iwlist scan' finds my ap, but that not
>   everytime. I can't connect to my wlan at all.
> - driverloader: sometimes works for some seconds (last evening some
>   minutes). The connection was much better than with madwifi.
> With driverloader I get this kernel message:
> NETDEV WATCHDOCH: eth1: transmit timed out
> see also:
> http://wulf.eu.org/stuff/driverloaderdiag.txt
> Hope you can help me, tia!
> Joern Heissler
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list