[driverloader] wlan0 driver startup problem

Linuxant support (Jonathan) support at linuxant.com
Sun Sep 19 14:16:54 EDT 2004


if you have a CardBUS (32-bit PCMCIA) wireless device, please make sure 
that the 'pcmcia' service is started before the 'network' service.

If you need to change the starting order of your services under SuSE, 
please follow these instructions :

Please take a look at both the '/etc/init.d/network' and the 
'/etc/init.d/pcmcia' files. In each file, you should see a line like this :

# chkconfig <run level number> <start prio number> <kill prio number>

Then, please edit the '/etc/init.d/pcmcia' file and change the <start 
prio number> to the <start prio number> found in the 
'/etc/init.d/network' file minus one. You will also have to change the 
<kill prio number> which can be calculated with this simple formula :

<kill prio number> = 100 - <start prio number>

After the modifications have been made to the '/etc/init.d/pcmcia' file, 
please run the following command in a root shell :

chkconfig pcmcia reset


Technical specialist / Linuxant
support at linuxant.com

Jim Sabatke wrote:
> SuSE 9.0
> 2.4.21
> HP ZD7260US
> When I boot, my net connection doesn't start.  I have to bring up the 
> interface and do a "restart". Then ifup wlan0 connnects.
> I've tried putting a few things in my boot.local file, but nothing has 
> worked.
> What and where do I need to put things to get this thing to boot with 
> the network up?
> Thanks,

More information about the driverloader mailing list