[driverloader] Cisco 350 MiniPCI, WPA -- any success stories?

Stefan Patric tootek2 at yahoo.com
Tue Sep 28 23:13:58 EDT 2004

--- Steven Ihde <x-driverloader at hamachi.dyndns.org>

> I'm trying to get the Cisco 350 MiniPCI adapter in
> my ThinkPad T30 to
> work with WPA-PSK security.  I'm running Debian
> sarge with the
> prebuilt 2.6.8-1-686 kernel.
> Does anybody have success or failure stories to
> report?  I haven't seen any
> reports out there describing success or failure
> either way.
> I'll describe the problems I'm having.  Installation
> seemed to go
> fine.  After a cold boot, encouraging messages
> appear in the log (note
> WPA is listed as supported):
> Sep 28 15:13:29 localhost kernel: wlan0: New link
> status: Disconnected (0002)
> Sep 28 15:13:29 localhost kernel: wlan0: WPA, TKIP,
> WEP128, WEP64 supported
> Sep 28 15:13:29 localhost kernel: wlan0: Cisco
> Systems352 series Wireless LAN Adapter. at
> 0000:02:02.0 (MAC address 00:02:8A:5C:84:58) ready
> Then I issue "ifconfig wlan0 up", followed by
> "wpa_supplicant -dd -c
> /etc/wpa_supplicant.conf -i wlan0" and this shows up
> in the kernel
> log:
> Sep 28 15:20:33 localhost kernel: driverloader:
> ndisQueryInformation: 802_11_BSSID_LIST
> wpa_supplicant acts like it's timing out.
> After killing wpa_supplicant, "iwlist wlan0
> scanning" returns "wlan0:
> Interface doesn't support scanning : Operation not
> supported".
> However, if the very first thing I do after booting
> is "iwlist wlan0
> scanning", it seems to work exactly once (returning
> the correct list
> of SSIDs in this area) -- then the next time I run
> iwlist, it's
> "Failed to read scan data" and the same
> NOT_SUPPORTED message shows up
> in the kernel log.
> Any idea what's going on here?

I had similar problems with my D-Link 520 card, 2.4.22
kernel, Slackware 9.1.  After three weeks of trying, I
finally got it and wpa_supplicant working.  Here's my

   1.  Set SSID Broadcast to ENABLED on your wireless
route.  Otherwise, nothing will work.  (I don't know
why.  The Windows machines and the Mac work just fine
with Broadcast disabled.)

   2.  Turn off ALL security on your router.  Maybe,
even do a hardware reset to the default settings.  If
it's in the general startup, comment out
wpa_supplicant so it won't run.

   3.  Cold boot your machine and see if your card
connects.  If it does, test that all is working
properly.  If it doesn't, post what did happen here.

   4. Now, while your card is still connected, turn on
wpa-psk on your router.  Your card should still show
it's "up", but of course it won't communicate.  Run
wpa_supplicant with the -d debug option, and see if it
authenticates.  If it does, test that everything is
working.  If it doesn't, you know...

   5.  If #4 above worked, do a Ctrl-C in
wpa_supplicant's terminal, and rerun it with the -B
background option, and test that everything is

   6.  If #5 worked, then put wpa_supplicant with the
-B and -w (wait) options in the startup, cold boot,
and see if everything works.  I put the wpa_supplicant
call in /etc/rc.d/rc.inet1, which brings up lo
loopback interface and the ethernet card(s), as the
very first line of the script before lo or any of the
network hardware is up.  Hence, the need for the -w

Wireless on my system now works just fine. 
wpa_supplicant even renegotiates, if the wireless link
goes down, which it does periodically, and I have yet
to discover why.  I also have trouble with my cell and
the portable phone in the house.  They both operate at
2.4 GHz, same as the wireless network.  Probably

Hope this helps.


PS.  MY wireless card comes up as eth0, not wlan0. 
Shouldn't make a difference with the above procedure.

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the driverloader mailing list