[driverloader] kernel oops on X11 shutdown with stk16 kernel

Rich Ibbotson richibb at rochester.rr.com
Sun Oct 3 12:52:22 EDT 2004

Thanks, Jonathan.  It looks like that doesn't help for my case (intel centrino with XP drivers).
I still get messages indicating that I need to use a kernel with >4K stack size.


Jonathan Baron wrote:
> On 10/03/04 08:00, Rich Ibbotson wrote:
>>Hi all,
>>I'm having some difficulties getting driverloader running on my Fedora
>>Core 2 system.  Actually, it's not the driverloader code that is the
>>problem, it's the "stk16" kernel that I'm using to get around the 4k
>>stack restriction in the FC2 kernel.
>>The problem:
>>When I boot using the 2.6.8-1.521.stk16.i686 replacement kernel, running
>>in runlevel 5, all is well until I log out of a kde session.  At that
>>point, instead of getting a graphical login screen, the X server crashes
>>and I see a kernel oops. I've included the relevant bits of
>>/var/log/messages and /var/log/Xorg.0.log below.
>>Note that I am not sure whether or not this is due to the 4k/16k patch.
>>I've built a kernel from the sources for 2.6.8-1.521 (from Fedora Core
>>2) with only the change to disable 4 GB kernel-space/user-space vm
>>support (no 16k stack patch), and I see slightly different problems -
>>sometimes an oops at logout, sometimes a system freeze when I log in
>>graphically, sometimes it works fine.
>>Any ideas?  I've tried building a custom kernel starting from the stk16
>>source but re-enabling 4G/4G virtual memory - the resulting kernel
>>doesn't even boot.  Last thing I see is "Uncompressing Linux... OK,
>>booting the kernel".
> With Fedora Core 2 and the 2.6.8-1.521 kernel (the latest),
> driverloader works for me WITHOUT using a modified kernel (either
> custom or the stk16 from Linuxant).  You might try that.  I did
> do the following:
> dldrconfig --enable-workaround=stack

More information about the driverloader mailing list