[driverloader] Suse 9.2 and broadcom BCM4306

Ian K. Harrell fireman71 at trificient.net
Mon Dec 6 22:03:46 EST 2004

Hello everyone,

Running into a slight problem....

I was running a copy of Suse 9.0 for evaluating installing linux on a
few of our laptops and had driverloader working with it.

Decided to make a real go on one system and installed Suse 9.1
Professional, did all the updates to Suse via "you" and then got the
correct version of driverloader and installed it via rpm.

When enter ifup wlan0 to activate the device I get the following error:

wlan0		device: Broadcom Corporation BCM4306 802.11b/g Wireless
LAN Controller (rev 03)
wlan0		warning: using NO encryption
ERROR: Error while executing:
	Command 'ip route replace to dev wlan0' returned:
	RTNETLINK answers: No such device
	Configuration line: - wlan0
SuSEfirewall2: Warning: no interface active
SuSEfirewall2: Firewall rules successfully set from

This is on a Dell Inspiron 1150 laptop with a minipci  dell 1350 802.11g
card. The dell 1350 card uses the broadcom 4306 driver or at least did
when I had Suse 9.0 installed on the same computer.

Also the command iwlist scan can see the wireless network so I am
thinking that I have missed something with iwconfig and with me it is
probably something simple.

The iwconfig command I use is as follows:

iwconfig wlan0 essid "fireman71" mode Managed nick "laptop1"

and that is the same line I used under Suse9.0 when everything worked

Is there something else I need to add or am I just missing something

IK Harrell

More information about the driverloader mailing list