[driverloader] can't get wpa_supplicant to authenticate TKIP

Linuxant support (Jonathan) support at linuxant.com
Wed Dec 29 09:44:03 EST 2004


for DriverLoader, you should compile the wpa_supplicant package with the 
CONFIG_DRIVER_HOSTAP option. Did you tried with ESSID broadcasting enabled?

If you are not already doing so, please try with the version of the 
wpa_supplicant package that you can download at the bottom of our 
DriverLoader download page at :



Technical specialist / Linuxant
support at linuxant.com

rcbell at cox.net wrote:
> I'm having no luck getting WPA authentication going with wpa_supplicant.
> I'm running SuSE 9.1 Pro, using Linksys G equipment: WRT54GS AP/router and WMP54GS PCI adapter card.  I've successfully loaded the linksys drivers with driverloader, and when I turn off authentication in the AP I connect fine (using SSID broadcast both on and off).  I build wpa_supplicant with the default .config.  My wpa_supplicant.conf contains:
> network={
>          ssid="myssid"
>          psk="11111111"
>          key_mgmt=WPA-PSK
>          pairwise=CCMP TKIP
>          group=CCMP TKIP
>         }
> (but I've also tried it with only the ssid and psk values).
> Of course, the ssid and psk are the same that I've entered on the Wireless tab of the router setup.  
> Most everyone on this list that has this is using AES.  Has anyone gotten TKIP to work?
> I was also wondering if the default .config is correct for driverloader, since it uses CONFIG_DRIVER_HOSTAP (the README hardly mentions driverloader).
> The main error message with -dd seems to be "Authentication with 00:00:00:00:00:00 timed out" then it starts the loop again.  I also see several "wpa_driver_hostap_set_key: alg=none key_idx=0 set_tx=0 seq_len=0 key_len=0" type of messages.
> Any ideas?
> Craig Bell
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list