[driverloader] can't get wpa_supplicant to authenticate TKIP

Craig Bell rcbell at cox.net
Wed Dec 29 12:21:15 EST 2004

Stefan Patric wrote:

>I'm using the Linksys WRT-54G, but with a D-Link
>DWL-520 card.  My wpa_supplicant.conf is similar. 
>Same protocols.
>Sometimes, wpa_supplicant won't authenticate if run
>after your wireless card comes up.  Or if it does, the
>IP and Gateway addresses don't get passed to the card.
> My work-around was to start wpa_supplicant in the
>Background & Wait mode (-Bw) before the network card
>came up.  You'll have to find which rc script this is.
> It varies depending on which distro you're using.
>I just got a message yesterday from Johnathan,
>Linuxant's tech, that if you are using driverloader
>version 2.07 or later, if you rename the
>wpa_supplicant executable dldr_wpa_supplicant and put
>it in /usr/sbin instead of /usr/local/bin where the
>docs tell you to put it, and if you put
>wpa_supplicant.conf in /etc/driverloader/ renamed
>dldr_wpa_supplicant.<iface>.conf, where <iface> is
>your wireless device's name (mine is eth0), it will
>automatically be started when the wireless interface
>is.  I don't know, if this will work as I haven't yet
>had time to implement it.
>(This little tid-bit wasn't in any of the driverloader
>docs.  At least, not that I could find.  And I looked
>after I got the message from Johnathan.)
Thanks!!! Using these instructions and rebooting, I got it up and 
running. <Hooray!>

I should have mentioned that I was trying to start wpa_supplicant from 
the shell.  I tried starting it and then bringing up the network with 
"ifconfig wlan0 up" and vice versa.  I tried not using the -b flag and 
using it, etc.  I had not rebooted since installing driverloader and 
wpa_supplicant, so I copied the files over and voila.  The README seemed 
to imply that it should have worked from the shell- does anyone have any 
input on this?

Thanks again,
Craig Bell

More information about the driverloader mailing list