[driverloader] Broadcom (Belkin 54g) AMD64

tschiller at llamabox.com tschiller at llamabox.com
Sun Jan 23 00:44:01 EST 2005

driver loader is  not finding my Belkin G card. anyone have anyclue as
to why? thanks.

lspci reports this:

0000:00:0d.0 Network controller: Broadcom Corporation BCM4306 802.11b/g
Wireless LAN Controller (rev 02)

dmesg contains the following:

Bootdata ok (command line is root=/dev/hda4)
Linux version 2.6.10-gentoo-r4 (root at livecd) (gcc version 3.4.2 (Gentoo
Linux 3.4.2-r2, ssp-3.4.1-1, pie- #1 Sat Jan 15 08:01:07 CST
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003ffb0000 (usable)
 BIOS-e820: 000000003ffb0000 - 000000003ffc0000 (ACPI data)
 BIOS-e820: 000000003ffc0000 - 000000003fff0000 (ACPI NVS)
 BIOS-e820: 000000003fff0000 - 0000000040000000 (reserved)
 BIOS-e820: 00000000ff780000 - 0000000100000000 (reserved)
No mptable found.
On node 0 totalpages: 262064
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 257968 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
ACPI: RSDP (v000 ACPIAM                                ) @
ACPI: RSDT (v001 A M I  OEMRSDT  0x10000427 MSFT 0x00000097) @
ACPI: FADT (v001 A M I  OEMFACP  0x10000427 MSFT 0x00000097) @
ACPI: MADT (v001 A M I  OEMAPIC  0x10000427 MSFT 0x00000097) @
ACPI: OEMB (v001 A M I  OEMBIOS  0x10000427 MSFT 0x00000097) @
ACPI: DSDT (v001  A0036 A0036001 0x00000001 MSFT 0x0100000d) @
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Processor #0 15:15 APIC version 16
Using ACPI for processor (LAPIC) configuration information
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: ASUSTeK  <6>Product ID: Deluxe       <6>APIC at: 0xFEE00000
I/O APIC #1 Version 3 at 0xFEC00000.
Setting APIC routing to flat
Processors: 1
Checking aperture...
CPU 0: aperture @ e0000000 size 128 MB
Built 1 zonelists
Kernel command line: root=/dev/hda4 console=tty0
Initializing CPU#0
PID hash table entries: 4096 (order: 12, 131072 bytes)
time.c: Using 1.193182 MHz PIT timer.
time.c: Detected 2202.862 MHz processor.
Console: colour VGA+ 80x25
Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Memory: 1025744k/1048256k available (2756k kernel code, 21844k reserved,
954k data, 180k init)
Calibrating delay loop... 4308.99 BogoMIPS (lpj=2154496)
Mount-cache hash table entries: 256 (order: 0, 4096 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 512K (64 bytes/line)
CPU: AMD Athlon(tm) 64 Processor 3400+ stepping 00
Using local APIC NMI watchdog using perfctr0
Using IO-APIC 1
Using local APIC timer interrupts.
Detected 12.516 MHz APIC timer.
NET: Registered protocol family 16
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router default [1106/3227] at 0000:00:11.0
PCI->APIC IRQ transform: (B0,I7,P0) -> 169
PCI->APIC IRQ transform: (B0,I10,P0) -> 177
PCI->APIC IRQ transform: (B0,I11,P0) -> 169
PCI->APIC IRQ transform: (B0,I12,P0) -> 177
PCI->APIC IRQ transform: (B0,I13,P0) -> 185
PCI->APIC IRQ transform: (B0,I15,P1) -> 193
PCI->APIC IRQ transform: (B0,I15,P0) -> 193
PCI->APIC IRQ transform: (B0,I16,P0) -> 201
PCI->APIC IRQ transform: (B0,I16,P0) -> 201
PCI->APIC IRQ transform: (B0,I16,P1) -> 201
PCI->APIC IRQ transform: (B0,I16,P1) -> 201
PCI->APIC IRQ transform: (B0,I16,P2) -> 201
PCI->APIC IRQ transform: (B0,I17,P2) -> 209
PCI->APIC IRQ transform: (B1,I0,P0) -> 169
agpgart: Detected AGP bridge 0
agpgart: Maximum main memory to use for agp memory: 941M
agpgart: AGP aperture is 128M @ 0xe0000000
PCI-DMA: Disabling IOMMU.
IA32 emulation $Id: sys_ia32.c,v 1.32 2002/03/24 13:02:28 ak Exp $
devfs: 2004-01-31 Richard Gooch (rgooch at atnf.csiro.au)
devfs: boot_options: 0x1
Installing knfsd (copyright (C) 1996 okir at monad.swb.de).
NTFS driver 2.1.22 [Flags: R/O].
inotify device minor=63
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
Hangcheck: starting hangcheck timer 0.5.0 (tick is 180 seconds, margin
is 60 seconds).
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
elevator: using anticipatory as default io scheduler
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
eth0: Yukon Gigabit Ethernet 10/100/1000Base-T Adapter
      PrefPort:A  RlmtMode:Check Link State
netconsole: not configured, aborting
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with
Probing IDE interface ide0...
hda: WDC WD1600JB-00DUA3, ATA DISK drive
hdb: ST340810A, ATA DISK drive
Probing IDE interface ide1...
hdd: ARTEC WRR-4848 1.00, ATAPI CD/DVD-ROM drive
Probing IDE interface ide2...
ide2: Wait for ready failed before probe !
Probing IDE interface ide3...
ide3: Wait for ready failed before probe !
Probing IDE interface ide4...
ide4: Wait for ready failed before probe !
Probing IDE interface ide5...
ide5: Wait for ready failed before probe !
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 1024KiB
hda: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63
hda: cache flushes supported
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
hdb: max request size: 128KiB
hdb: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63
hdb: cache flushes not supported
 /dev/ide/host0/bus0/target1/lun0: p1
hdc: ATAPI 32X DVD-ROM CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 48X CD-ROM CD-R/RW drive, 2048kB Cache
3ware Storage Controller device driver for Linux v1.26.02.000.
libata version 1.10 loaded.
sata_via version 1.0
sata_via(0000:00:0f.0): routed to hard irq line 1
ata1: SATA max UDMA/133 cmd 0xC000 ctl 0xB802 bmdma 0xA800 irq 193
ata2: SATA max UDMA/133 cmd 0xB400 ctl 0xB002 bmdma 0xA808 irq 193
ata1: no device found (phy stat 00000000)
scsi0 : sata_via
ata2: no device found (phy stat 00000000)
scsi1 : sata_via
ehci_hcd 0000:00:10.4: EHCI Host Controller
ehci_hcd 0000:00:10.4: BIOS handoff failed (104, 1010001)
ehci_hcd 0000:00:10.4: continuing after BIOS bug...
ehci_hcd 0000:00:10.4: irq 201, pci mem 0xfbc00000
ehci_hcd 0000:00:10.4: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:10.4: USB 2.0 initialized, EHCI 1.00, driver 26 Oct
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 8 ports detected
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
USB Universal Host Controller Interface driver v2.2
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: irq 201, io base 0xc400
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: irq 201, io base 0xc800
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: irq 201, io base 0xd000
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
uhci_hcd 0000:00:10.3: UHCI Host Controller
uhci_hcd 0000:00:10.3: irq 201, io base 0xd400
uhci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 5
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 2 ports detected
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usb 2-1: new low speed USB device using uhci_hcd and address 2
usb 2-1: device descriptor read/64, error -71
usb 2-2: new full speed USB device using uhci_hcd and address 3
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver ati_remote
drivers/usb/input/ati_remote.c: Registered USB driver ATI/X10 RF USB
Remote Control v. 2.2.1
input: USB HID v1.00 Mouse [ARROW STRONG USB 3D Mouse] on
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
Advanced Linux Sound Architecture Driver Version 1.0.6 (Sun Aug 15
07:17:53 2004 UTC).
via82xx: Assuming DXS channels with 48k fixed sample rate.
         Please try dxs_support=1 or dxs_support=4 option
         and report if it works on your machine.
PCI: Setting latency timer of device 0000:00:11.5 to 64
ALSA device list:
  #0: VIA 8237 with ALC850 at 0xd800, irq 209
oprofile: using NMI interrupt.
NET: Registered protocol family 2
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
NET: Registered protocol family 1
NET: Registered protocol family 10
IPv6 over IPv4 tunneling driver
NET: Registered protocol family 17
ReiserFS: hda4: found reiserfs format "3.6" with standard journal
ReiserFS: hda4: using ordered data mode
ReiserFS: hda4: journal params: device hda4, size 8192, journal first
block 18, max trans len 1024, max batch 900, max commit age 30, max
trans age 30
ReiserFS: hda4: checking transaction log (hda4)
ReiserFS: hda4: Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 180k freed
Adding 996020k swap on /dev/hda3.  Priority:-1 extents:1
parport_pc: Ignoring new-style parameters in presence of obsolete ones
parport0: PC-style at 0x378 (0x778) [PCSPP(,...)]
parport0: irq 7 detected
warning: many lost ticks.
Your time source seems to be instable or some driver is hogging
rip __do_softirq+0x48/0xb0
NTFS volume version 3.1.
eth0: network connection down
driverloader: module license 'see LICENSE file; Copyright (c)2003-2004
Linuxant inc.' taints kernel.
driverloader: stack=8192/88/0 REGPARM
usbcore: registered new driver driverloader
eth0: network connection up using port A
    speed:           100
    autonegotiation: yes
    duplex mode:     full
    flowctrl:        symmetric
    irq moderation:  disabled
    scatter-gather:  enabled
eth0: no IPv6 routers present

More information about the driverloader mailing list