[driverloader] Similar multiple problems dl2.24 / SuSE9.2 amd64 / bcm4306

Eric Herget eherget at bellsouth.net
Sat Mar 5 12:32:51 EST 2005

More info...

I installed driverloader 2.25 and put the memory config back to 1x256MB 
and 1x1GB memory modules.  I still see the same behavior with CPU being 
used at 100% and keyboard input messed up on the 2.6.11 kernel.

Another piece of info I had fogotten to mention - if I run `dldrconfig 
-k` after the machine boots while the wireless card is deactivated, then 
activate the card, all works fine.  This happens on both the 2.6.8-24.11 
kernel and 2.6.11.

Is it possible driverloader has a dependency on a kernel module on my 
system that most others might have built in to the kernel?


Eric Herget wrote:

> Hi Jonathan,
> Yes, this one is a strange one.  You mention not being able to scan 
> for an access point.  I haven't had that problem - possibly this was 
> the other person who posted a similar problem with keyboard input 
> being messed up.
> I've checked my kernel config and I do not have CONFIG_PREEMPT set.  I 
> cannot even find CONFIG_4KSTACKS in my config so it is presumably also 
> unset.
> I also put back my original memory configuration and, surprisingly, 
> everything works as expected.  So I'll sum up where we're at so far:
> - Common config -
> SuSE9.2
> AMD64
> HP Pavilion zv5340us notebook
> Broadcom BCM4306 802.11b/g Wireless LAN Controller (rev 03)
> bcmwl564 driver (as linked to from your website)
> - In chronological order -
> Got driverloader working with 64-bit Broadcom driver linked from you 
> website on kernel v 2.6.8-24.11 with 512MB memory in notebook (2 x 
> 256MB  memory modules).
> Changed out 1  256MB memory module for 1GB memory module still on 
> kernel v 2.6.8-24.11 and now system hangs if wireless device is 
> activated.  Hangs at boot when starting driverloader if wireless card 
> is active at boot time.  If I activate the wireless card using button 
> above keyboard after system has booted, the system hangs immediately 
> (no network access, etc).  In both cases hard reboot is necessary.  
> Did not see any related messages in dmesg output or /var/log/messages.
> Dl'd, compiled and installed kernel 2.6.11, did dldrconfig -k, etc.  
> with same memory config as above (1x  256MB and 1x 1GB memory 
> modules).  If wireless device is activated, "kdldrd/dpc" process eats 
> up all available CPU and keyboard input behavior is strange.  
> Deactivating wireless device seems to put system back in its normal 
> state - normal CPU usage and keyboard input is normal.   I have not 
> looked at dmesg output or /var/log/messages in this case - that's next.
> Put memory configuration back to 2x256MB memory modules, still with 
> 2.6.11 kernel and all works as expected.
> I'm now gonna put the memory back to 1x256MB and 1x1GB configuration 
> and look for anything in dmesg output and/or /var/log/messages.  Then 
> I'll dl driverloader 2.25 and see if that has any affect.
> Out of curiosity, where did the 64-bit broadcom drivers come from?  
> Are they beta version drivers?
> Eric
> Linuxant support (Jonathan) wrote:
>> Hi,
>> this is s strange problem, when you are unable to scan for an access 
>> point and the characters which are repeated, it could be an interrupt 
>> related problem.
>> Eric, if you put back the memory setup you had before with 
>> DriverLoader does it fix the problem?
>> You could also check that you kernel was not compiled with one of the 
>> following options:
>> ---
>> ---
>> If your kernel each compiled with one of these options enabled, 
>> please disable it, re-compile the kernel and finally re-compile the 
>> DriverLoader module with the 'dldrconfig -k' command in a root shell.
>> You could also try to use your wireless card under Windows XP to see 
>> if you have a similar problem.
>> Regards,
>> Jonathan
>> Technical specialist / Linuxant
>> www.linuxant.com
>> support at linuxant.com
>> eherget at bellsouth.net wrote:
>>> I, too, have similar problems.
>>> I have a Pavilion zv5340us notebook - AMD64, Broadcom 802.11 
>>> built-in, etc.
>>> I had written before about problem with the button at the top of the 
>>> keyboard that activates/deactivates the wireless device.  I had 
>>> gotten it all working nicely...
>>> ...but then I added more memory.  The notebook has 2 memory "slots", 
>>> one is easily reachable behind an access panel, the other requires 
>>> some disassembly to get to the slot under the keyboard.  I replaced 
>>> the easily reachable 256MB memory module with a 1GB module - the 
>>> other slot still has a 256MB module.
>>> Since then, my machine would hang when starting Driverloader during 
>>> boot if the device was activated (device activation state is 
>>> controlled by the button above the keyboard and is persistent 
>>> between reboots/power off-on).  This on kernel 2.6.8-24.11.  If the 
>>> device is off during boot the machine comes up fine, but pressing 
>>> the button to activate the wireless device causes the system to lockup.
>>> Yesterday I dl'd the newest kernel 2.6.11 and with the fix mentioned 
>>> in a post earlier today, I tried driverloader with it.
>>> Now, instead of locking up, the system has its CPU pegged at ~100%.  
>>> But I was able to see that a process called "kdldrd/dpc" was eating 
>>> up all this usage.  As with the most recent post that I've forwarded 
>>> here, the keyboard input is strange.  In my case, same letters typed 
>>> with other letters in between got jumbled.  For example, I would 
>>> type "dldrconfig" and what showed up on screen a few seconds later 
>>> was "ddlrconfig".  Or  "10802" became "10082".   Unlike the post I 
>>> forwarded, mine is a single CPU system.
>>> With the 2.6.11 kernel, I could press the button to deactivate the 
>>> wireless device and the system would go back to normal (CPU usage OK 
>>> and keyboard input OK).  On the 2.6.8-24.11 kernel, once the system 
>>> locked up, deactivating the wireless device did not free up the system.
>>> Eric
>>>> From: "Martin A. Brooks" <martin at hinterlands.org>
>>>> Date: 2005/03/03 Thu AM 11:03:36 EST
>>>> To: driverloader at lists.linuxant.com
>>>> Subject: [driverloader] multiple problems dl2.24 / debian amd64 / 
>>>> Belkin
>>>>     bcm4306 based card
>>>> Hi
>>>> I'm experiencing three problems with driverloader 2.24.  Firstly, 
>>>> what does work:
>>>> Driverloader compiles for my kernel (2.6.10) and allows me to 
>>>> upload the driver for the wireless card.  The wireless card is 
>>>> detected correctly and appears as eth1, I am able to use ifconfig 
>>>> to configure the interface.
>>>> My problems are:
>>>> 1) I cannot reach my accesspoint. Even with the correct ESSID set 
>>>> the AP is not detected by the iw utilities.  I am not able to ping 
>>>> known up and known working hosts on the network.
>>>> 2) The kernelspace driverloader process consumes 100% of one CPU  
>>>> (I have a dual opteron 242). This hits performance quite a lot, as 
>>>> you can imagine.
>>>> 3) With driverloader in residence I get keyboard glitches under X  
>>>> (not under the console).  Typing "martin at hinterlands.org" for 
>>>> example, will usually look something like 
>>>> "marrrrrrrrrrrrrrrrrrrrtin at hinttttttttttttttttttttterlaaaaaaaaands.orrrrrrrrrg".  
>>>> If I unload the driverloader module then all is well.
>>>> Any hints appreciated
>>>> Regards
>>>> Martin A. Brooks
>>>> _______________________________________________
>>>> driverloader mailing list
>>>> driverloader at lists.linuxant.com
>>>> https://www.linuxant.com/mailman/listinfo/driverloader
>>> _______________________________________________
>>> driverloader mailing list
>>> driverloader at lists.linuxant.com
>>> https://www.linuxant.com/mailman/listinfo/driverloader
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list