[driverloader] "Invalid module format" error on AMD64 w/ kernel 2.6.10

Linuxant support (Jonathan) support at linuxant.com
Wed Mar 16 09:38:53 EST 2005


you must not only uncomment the line "CC=gcc" in the file 
"modules/Makefile", you must also change it to point it to an 
installation of gcc 3.3.x on your system. For example, it could be 
"CC=/usr/local/bin/gcc" or "CC=/usr/bin/gcc-3.3" depending on how you 
system was configured.

Alternatively, you could try to download your gcc version to a 3.3.x 
version to be able to build kernel modules for your '2.6.10-9-amd64-k8' 
kernel. You could also instead install a kernel which was compiled with 
gcc 4.0.x.


Technical specialist / Linuxant
support at linuxant.com

David Leaman wrote:
> Hello,
> I've seen one or two problems similar to mine in the archives, but their
> fixes don't seem to work on my system (Debian GNU/Linux 2.6.10-9-amd64-k8;
> Compaq Presario R3000 series). Here're the symptoms:
> driverloader-2.26# make install
> [no errors in output]
> driverloader-2.26# dldrconfig
> [prompts and builds modules]
> [...]
> done.
> driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
> '2.6.10-9-amd64-k8 gcc-3.4'[informational output]
> To complete the installation please point your browser to:
> driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
> '2.6.10-9-amd64-k8 gcc-3.4'
> driverloader-2.26# modprobe driverloader
> driverloader: version magic '2.6.10-9-amd64-k8 gcc-3.3' should be
> '2.6.10-9-amd64-k8 gcc-3.4'
> FATAL: Error inserting driverloader
> (/lib/modules/2.6.10-9-amd64-k8/extra/driverloader.ko): Invalid module
> formatdriverloader-2.26#
> I then try editing the Makefile, which is what I saw mentioned as a
> solution in one of the threads. I `make uninstall` then uncomment line 65
> in modules/Makefile:CC=gcc
> Then I follow the steps above and get exactly the same result. I also try
> doing the same thing, but commenting out line 66:
> CC := $(shell $(TOP)/modules/kernelcompiler.sh $(KERNELVER)
> $(DLDR_KERNELSRC))I repeat the same steps with 'gcc-3.4' and 'gcc-3.3'. Each time I get the
> same result: the build seems to work fine, but dldrconfig and modprobe
> error out.
> I've tried every combination of fixes I can think of. Can someone please
> point me in the right direction?
> You can find the output of `dldrconfig --dumpdiag` here:
> http://pimpninja.org/txt/driverloaderdiag.txt
> Thank you,
> -D

More information about the driverloader mailing list