[driverloader] Need help troubleshooting FC3 wireless setup

John Pedersen charles.pedersen at sri.com
Thu Apr 21 07:40:36 EDT 2005


Great job on driverloader.  It operates exactly as advertised.  I had no 
problems installing it on my T40p thinkpad under FC3, using your 
precompiled 16k stack kernel.

It was working perfectly using system-config-network to configure it as 
required.  (I have wireless at home and at least two different networks 
at work.)

Because I  do move among different wireless networks, I decided to set 
up profiles in the FC network configuration applet.  It didn't seem to 
work, so I deleted the profiles and just went back to the common 
profile.  Not entirely sure what I did, but I seemed to have blown away 
some important config information.  Every time I would try to active the 
wireless interface (eth1 in this case) I got a message about "usage ifup 
<device name>".

Tried bringing everything up by hand to see what would happen.

After I had booted, I ran iwlist scan and confirmed that driverloader 
seemed to behaving properly.

Then I ran iwconfig eth1 essid "essid from scan" and iwconfig eth1 key 
<key for the ap>

Then I ran iwconfig eth1 and confirmed the right values were set.  They 

Then I attempted to run dhclient by hand by doing:

[root at traveler ~]# dhclient eth1
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

/sbin/dhclient-script: configuration for eth1 not found. Continuing with 
/etc/sysconfig/network-scripts/network-functions: line 47: eth1: No such 
file or directory
Listening on LPF/eth1/00:05:4e:42:2c:5a
Sending on   LPF/eth1/00:05:4e:42:2c:5a
Sending on   Socket/fallback
DHCPREQUEST on eth1 to port 67
/sbin/dhclient-script: configuration for eth1 not found. Continuing with 
/etc/sysconfig/network-scripts/network-functions: line 47: eth1: No such 
file or directory
bound to -- renewal in 40657 seconds.

eth1      Link encap:Ethernet  HWaddr 00:05:4E:42:2C:5A
         inet addr:  Bcast:  Mask:
         inet6 addr: fe80::205:4eff:fe42:2c5a/64 Scope:Link
         RX packets:52 errors:0 dropped:0 overruns:0 frame:0
         TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
         collisions:0 txqueuelen:1000
         RX bytes:48920 (47.7 KiB)  TX bytes:4663 (4.5 KiB)

As you can see, after a lot of complaining, dhclient finally bound to which was the correct address and correctly identified as the dhcp server.  But apparently no dns server 
information was obtained.  (I looked in /etc/resolv.conf and it hadn't 
been updated with the dns server for my home ISP)

I've probably gone about this backward, but I'd appreciate it if someone 
could point me in the right direction.

On a separate note, has anyone experimented with wlassistant (works, but 
requires install of dhcpd for full functionality) or NetworkManager?  
Any other AP discovering, help you in the connection apps out there?

Any place to go to get better information about system-config-network?  
The encryption key part of it doesn't seem to work, at least I always 
had to set it by hand using /sbin/iwconfig before and then activating 
the interface through the applet.

I did a dldrconfig dump although as far as I can tell, driverloader is 
doing its job just fine and I've totally screwed the interface 


John Pedersen

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 5211 bytes
Desc: S/MIME Cryptographic Signature
Url : http://www.linuxant.com/pipermail/driverloader/attachments/20050421/8b844384/smime.bin

More information about the driverloader mailing list