[driverloader] Open Suse 10 wlan1

Linuxant support (Jonathan) support at linuxant.com
Tue Jan 3 14:55:27 EST 2006


this is a known problem on SuSE 10.0. It is quite possible that the 
source of the problem is that DriverLoader and udev disagree with the 
name of the wireless interface.

You can change the name of the wireless interface used by DriverLoader 
with the 'dldrconfig --netdevname' command in a root shell. You can 
change the udev rule which associates the MAC address of the wireless 
device to the name of the wireless interface in a file in the 
'/etc/udev/rules.d' directory. Once you have changed the file, you must 
run the 'udevcontrol reload_rules' command in a root shell.

The patch you refer to was for a previous version of DriverLoader and it 
was included in DriverLoader 2.30. Since the patch was added to 
DriverLoader 2.30, it was removed from our web site.


Technical specialist / Linuxant
support at linuxant.com

Joe Woods wrote:
> Hi,
> I had this driver working for a while, and recently it's stopped working.
> It seems to be partially installed as wlan1, and partially installed as 
> wlan0
> When the system boots, it looks for files at /sys/class/net/wlan0 (but 
> it can't find it because it's installed to wlan1)
> Also, when I do iwconfig it's installed as wlan1 (but still doesn't work).
> I've tried re-installing, and runing dldrconfig --netdevname=wlan0, but 
> this has had no affect.
> I read in another post that there was a patch, but this seem to have 
> been taken down. It also says about setting up udev rules. I've no idea 
> what that means.
> Thanks for your help!
> -
> Joe Woods
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list