[driverloader] compile failed on FC5T2 kernel

Linuxant support (Jonathan) support at linuxant.com
Mon Jan 16 14:51:25 EST 2006


for the suspend issue on FC5 test, did you tried with different versions 
of the Windows XP driver, if available, to see if there is a difference? 
Did you tried with the vanilla 2.6.15 kernel from http://www.kernel.org 
as well?

For the compilation issue, please try the patch I have attached to this 
post, it should fix at least the following error:

/usr/lib/driverloader/modules/dldrusb.c:348: error: unknown field 
'owner' specified in initializer


Technical specialist / Linuxant
support at linuxant.com

Neal Becker wrote:
> This is Fedora 5 Test 2 x86_64:
>   CC [M]  /usr/lib/driverloader/modules/dldrusb.o
> In file included from /usr/lib/driverloader/modules/dldrusb.c:18:
> /usr/lib/driverloader/modules/GPL/netndis.h: In function 'netndis_lock':
> /usr/lib/driverloader/modules/GPL/netndis.h:181: warning: value computed is 
> not used
> /usr/lib/driverloader/modules/GPL/netndis.h:184: warning: value computed is 
> not used
> /usr/lib/driverloader/modules/GPL/netndis.h:189: warning: value computed is 
> not used
> /usr/lib/driverloader/modules/dldrusb.c: At top level:
> /usr/lib/driverloader/modules/dldrusb.c:348: error: unknown field 'owner' 
> specified in initializer
> /usr/lib/driverloader/modules/dldrusb.c:348: warning: missing braces around 
> initializer
> /usr/lib/driverloader/modules/dldrusb.c:348: warning: (near initialization for 
> 'dldrusb_driver.dynids')
> /usr/lib/driverloader/modules/dldrusb.c:348: warning: initialization makes 
> integer from pointer without a cast
> /usr/lib/driverloader/modules/dldrusb.c:348: error: initializer element is not 
> computable at load time
> /usr/lib/driverloader/modules/dldrusb.c:348: error: (near initialization for 
> 'dldrusb_driver.dynids.lock.raw_lock.slock')
> make[2]: *** [/usr/lib/driverloader/modules/dldrusb.o] Error 1
> make[1]: *** [_module_/usr/lib/driverloader/modules] Error 2
> make[1]: Leaving directory `/usr/src/kernels/2.6.15-1.1857_FC5-x86_64'
> make: *** [all] Error 2
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dldr-2.30-usb_driver_owner.patch
Type: text/x-patch
Size: 1391 bytes
Desc: not available
Url : http://www.linuxant.com/pipermail/driverloader/attachments/20060116/4c8a5bf8/dldr-2.30-usb_driver_owner.bin

More information about the driverloader mailing list