[driverloader] HSF driver install problems

Linuxant support (Jonathan) support at linuxant.com
Mon Nov 3 17:56:39 EST 2008


you have posted on the DriverLoader list instead of the HSF one. The HSF 
list information is available at:


That kind of error happens when the kernel headers are installed but not 
configured to build 3rd party kernel modules. Since you are using a 
kernel packaged with a Linux distribution, you will probably need to 
install all the configured kernel headers in order to use a generic 
package. On OpenSUSE, you can probably install this with the 'yast -i 
kernel-source' command in a root shell.


Technical specialist / Linuxant
support at linuxant.com

Rentner_Hans wrote:
> Hello,
> Some days ago I have purchased an internal modem card (Devolo mocrolink 
> 56k PCI; PCI ID: 14F1:2014 ), and I was trying to install a proper 
> driver for Opensuse linux 11.0 with a kernel
> I found  in  http://www.linuxant.com/drivers/hsf/downloads-license.php  
> your tool cnxtinstall.run. 
> <https://www.linuxant.com/drivers/hsf/full/archive/cnxtinstall.run>
> Also I found some files separately in 
> https://www.linuxant.com/drivers/hsf/full/downloads.php.
> And I tried to install the drivers with your automatic tool and with the 
> rpm-tool.
> But everytime I got  messages like
> snip-------
> warning: hsfmodem- Header V3 DSA signature: 
> NOKEY, key ID 5dfbf7dc
> Conexant HSF softmodem driver, version
> If you need license keys, assistance or more information, please go to:
>     http://www.linuxant.com/
> When reporting a problem for the first time, please send
> us the file generated by "hsfconfig --dumpdiag".
> No pre-built modules for: SuSE-11.0 linux- i686-SMP
> Trying to automatically build the driver modules...
> (this requires a C compiler and proper kernel sources to be installed)
> WARNING: the kernel version () defined in
> /usr/src/linux/include/linux/version.h
> does not match the currently running kernel (
> The cause of this problem is an incorrect kernel source path.
> Please check that /usr/src/linux points to the right tree.
> The cause of this is usually a missing or unconfigured
> kernel source tree (and sometimes an incorrect directory or symbolic link).
> However, proper /boot/config- was found.
> Unable to prepare temporary kernel tree
> First, ensure that the proper kernel source and compiler packages
> from your distribution vendor and/or the community are installed.
> The Linux kernel can then be reconfigured by running "make menuconfig"
> under the kernel source directory (usually /usr/src/linux).
> Verify that the proper options for your system are selected.
> Then compile and install your new kernel (for more information about
> this procedure, see the README file under the kernel source directory),
> reboot the system using the new kernel, and re-run "hsfconfig".
> error: %post(hsfmodem- scriptlet failed, exit 
> status 124
> snap --------
> In one webpage I found a remark, that "version.h" is never used in newer 
> kernel releases.
> Now I don't know how to go on.
> Have you any hint for me? (meanwhile I have tried it with another Suse 
> kernel, but w/o success)
> Please help me!
> -- 
> Mit freundlichem Gruß / Best regards
> Hans 
> ------------------------------------------------------------------------
> _______________________________________________
> driverloader mailing list
> driverloader at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/driverloader

More information about the driverloader mailing list