[hsflinux] Linmodem Problem continues : Thanks for many suggestions : None worked : Please help again

Sashti Srinivasan svasn_linux at yahoo.co.in
Wed Jan 7 04:20:28 EST 2004


  Thanks for continuously giving me suggestions till
now.  But I am yet to get my linmodem working.  I
provide a brief history here.  Please help me in
getting my linmodem running.

  * Caldera openlinux
  * Kernel sources are present at /usr/src/linux
  * Kernel sources are NOT installed seperately as
rpm, and list suggested that it is ok if kernel
sources are present in /usr/src/linux


  * First I tried
      rpm -ivh filename.rpm
    it failed saying failed dependency KERNEL_SOURCE

  * List suggested me to use --force and -p options
      rpm -i --force -p filename.rpm
    it failed saying unexpected query source

  * List then suggested me to remove the -p option and
it also reported the failed dependency KERNEL_SOURCE


  * I followed the instruction in the README file.
    Make got completed and instructed me to run
    I ran hsfconfig and it failed reporting the
    /usr/sbin/hsfconfig : ${param_hwinst[${unit}]} bad
    ERROR: hsfdriver not active

    I ran modprobe /dev/ttySHSF.  It failed reporting:
      unresolved symbol snprintf
      insmod /lib/modules/2/4/2/misc/hsfosspec.o

  * I approached list with an extra information that
came as warning from my system i.e., modules.dep older
than modules.conf
     List suggested me to run depmod -a -v. I ran that
it listed many errors all of them being failed
dependency AND all of them are related to 'hsf' as
evident from the filenames reported.


Yahoo! India Mobile: Download the latest polyphonic ringtones.
Go to http://in.mobile.yahoo.com

More information about the hsflinux mailing list