[hsflinux] Linmodem Problem continues : Thanks for many suggestions: None worked : Please help again

Linuxant support support at linuxant.com
Wed Jan 7 16:23:43 EST 2004


please try the following steps.

1- Uninstall the ".tar.gz" package by going in the directory where you
uncompressed it and running "make uninstall".

2- Install the "kernel-source" package from Caldera that matches your kernel
version. This has to be done before the next step.

3- Download and install the latest RPM of the generic driver. You will find
it under the title "Generic packages with source" on the download page.


4- Run "hsfconfig" to compile the driver modules.


Jean-Simon Durand
Technical specialist / Linuxant
support at linuxant.com

----- Original Message ----- 
From: "Sashti Srinivasan" <svasn_linux at yahoo.co.in>
To: <hsflinux at lists.linuxant.com>; <support at linuxant.com>
Sent: Tuesday, January 06, 2004 11:20 PM
Subject: [hsflinux] Linmodem Problem continues : Thanks for many
suggestions: None worked : Please help again


  Thanks for continuously giving me suggestions till
now.  But I am yet to get my linmodem working.  I
provide a brief history here.  Please help me in
getting my linmodem running.

  * Caldera openlinux
  * Kernel sources are present at /usr/src/linux
  * Kernel sources are NOT installed seperately as
rpm, and list suggested that it is ok if kernel
sources are present in /usr/src/linux


  * First I tried
      rpm -ivh filename.rpm
    it failed saying failed dependency KERNEL_SOURCE

  * List suggested me to use --force and -p options
      rpm -i --force -p filename.rpm
    it failed saying unexpected query source

  * List then suggested me to remove the -p option and
it also reported the failed dependency KERNEL_SOURCE


  * I followed the instruction in the README file.
    Make got completed and instructed me to run
    I ran hsfconfig and it failed reporting the
    /usr/sbin/hsfconfig : ${param_hwinst[${unit}]} bad
    ERROR: hsfdriver not active

    I ran modprobe /dev/ttySHSF.  It failed reporting:
      unresolved symbol snprintf
      insmod /lib/modules/2/4/2/misc/hsfosspec.o

  * I approached list with an extra information that
came as warning from my system i.e., modules.dep older
than modules.conf
     List suggested me to run depmod -a -v. I ran that
it listed many errors all of them being failed
dependency AND all of them are related to 'hsf' as
evident from the filenames reported.


More information about the hsflinux mailing list