[hsflinux] Linux 2.6.1 and connection-problems

Stefan Wagner wagner.stefan at berlin.de
Thu Feb 19 18:09:02 EST 2004


I'm using an older version (5.03.03, 5.03.27) of the hsfdriver since
about 15 months on my sony-vaio pcg fx-601, with via-chipset.

The modem is detected with the pci-id 1106:3068.

Now I compiled the new 2.6.1 linux-kernel.
I determined that the new kernel didn't cooperate with the old driver,
due to changes in the module-interface, so I downloaded the new
(restricted) 6.03.00lnxt04011900full driver - first as debian-package,
later as tarball.
It compiled without problems and is loaded when I start kppp.
It dials.
It connects.
Then, while changing the passwort with my ISP it disconnects.

I used the same settings as before, when running the linux-2.5.0 kernel.
I tried different settings (Pap, Chap, Pap/Chap).
I tried wvdial and manually setting the parameters with
ppp -(...params).

Mostly with the same results.
The modem hangs up.

The first time I had compiled my kernel with acpi, then with apm and
without acpi, then without both.

Allways the same result.

I activated debug-messages and kernel-debug-messages and here is a part
of my logfile:
- oh, no, the linebreaks!
I attach the whole file, and give here the most interesting lines:

44:36 pppd[758]: local  IP address
44:36 pppd[758]: remote IP address
44:36 pppd[758]: primary   DNS address
44:36 pppd[758]: secondary DNS address
44:36 pppd[758]: Script /etc/ppp/ip-up started (pid 767)
44:43 pppd[758]: Script /etc/ppp/ip-up finished (pid 767), status = 0x0
45:02 pppd[758]: Hangup (SIGHUP)
45:02 pppd[758]: Modem hangup
45:02 pppd[758]: Script /etc/ppp/ip-down started (pid 785)
45:02 pppd[758]: Connection terminated.
45:02 pppd[758]: Connect time 0.6 minutes.
45:02 pppd[758]: Sent 139 bytes, received 64 bytes.
45:02 pppd[758]: Waiting for 1 child processes...
45:02 pppd[758]:   script /etc/ppp/ip-down, pid 785
45:02 pppd[758]: Script /etc/ppp/ip-down finished (pid 785), status = 0x0
45:02 pppd[758]: Exit.

Any suggestions?

On linux-2.5.0, my eth0-card uses irq 10 and hsf irq 5.
On linux-2.6.1, both want to have irq 10 and suspicious messages occour 
about irq 5.

Might this be the problem?
The BIOS doesn't support setting of IRQs beneath Serial/Parallel port.

Don't visit my homepage at:

More information about the hsflinux mailing list