[hsflinux] Cannot open modem on Suse 9.1 - no such device or address

Linuxant support (Jonathan) support at linuxant.com
Mon Aug 23 16:06:38 EDT 2004


in the dump you have provided, we can see that you have the 'slamr' 
module in the output of the 'lsmod' command. This module often takes 
control of the modem, preventing the HSF driver to control your modem.

Since you are using SuSE 9.1, please add the following line in your 
'/etc/modprobe.conf.local' file :

install slamr /bin/true

Then, reboot your computer and try to use the modem.

For Mandrake 10, if you still want to use the modem driver on this 
distribution, please install the latest HSF driver package and then 
please send at support at linuxant.com a 'dumpdiag' that you can generate 
with the 'hsfconfig --dumpdiag' command in a root shell.


Technical specialist / Linuxant
support at linuxant.com

gab.cris at virgilio.it wrote:
> Hello
> I've been trying to activate my modem but it doesn't work...
> I've got  a Fujitsu-Siemens C1020, with Suse9.1 installed.
> The installation procedure detected my modem identifying it by "intel 537
> - (AC97 Modem)"
> and some of the vendor parameters were correct, though it put "slamr" driver.
> I executed scanModem and it seems to me the correct chipset is the Conexant
> one.
> I tried to use modem but it give me "no answer" after dialing.
> I so download hsf driver for Suse (x86) - the 14400 bps free  version -
> and installed it (rpm -i xxxx)
> i checked the lsmod output and I found various hsf xxx.
> but the modem still gives me "no answer" back. (after not checking 'wait
> for dialton':
> should i leave this check, i got "no dialtone" instead)
> I tried "hsfconfig" but it ends with :"ERROR: no device detected by hsf
> driver"
> I so tried by "modprobe ttySHSF0" and it sounds good;
> executing "dmesg" gives me back no errors at the end of files.
> I sincerely don't know how to proceed (the winmodem into XP runs ok)
> I previously had Mandrake 10.0 installed into my Fujitsu and I spent a week
> into trying to configure my modem, use all drivers i found into your site,
> (rpm, tar) compile, insert modules,
> changing initilization string of the modem.... I also copied the info of
> windows driver file into linux_via_smartmc.inf but the modem always gave
> So i install Suse9.1 hoping to resolve but I see the same problem....
> I executed hsfconfig --dumpdiag and got the  output.
> Im now attaching the log file i obteined hoping it will be useful...
> please help :)
> thank you... in advance.... should you need any other info let me know...
> bye for now
> Gabriele
> ------------------------------------------------------------------------
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list