[hsflinux] hsflinux: Cannot open modem on Suse9.1: NO CARRIER detection

gab.cris at virgilio.it gab.cris at virgilio.it
Wed Aug 25 11:36:01 EDT 2004

Hi again Jonathan

I just tried your  string AT &F X1 but it's the same..
i also added "pci=noapci" into kernel boot parameters but it doesn't work..
I'm not sure i understand when i have to pick up the phone..
my phone cable is connected into PC modem output... 
when shall I exactly pick up? my phone is not connected indeed...
..when I launch ATDTXXXXX I hear a click into my notebook but I can't hear
it dialing,
though I set "speaker on" into settings. Into XP mode, I hear the modem
I don't know how to proceed now.....
..if yu need other logs or other info please let me know.....
thanks for now for your kind help.... hope to see the light....


>-- Messaggio originale --
>To: gab.cris at virgilio.it
>Subject: Re: =?ISO-8859-15?Q?Re=3A=20=5Bhsflinux=5D=20Cannot=20open=20modem=20on=20Suse=209=2E1=20=2D=20no=20such=20device=20or=09address
>From: Linuxant support (Jonathan) <support at linuxant.com>
>Date: Tue, 24 Aug 2004 10:38:40 -0400 (EDT)
>it is possible that the problem is that the NVM settings are not the same
>in Windows and in Linux but this is rather uncommon as the source of
>problem. We will try something else first. This information is for SuSE
>this information is similar for Mandrake.
>You could try to use the following initilization string instead :
>AT &F X1
>If it doesn't help, please try to boot with the 'pci=noapci' kwernel boot
>If you require more assistance, please pick up the phone before you use
>'ATDTxxxxxx' command to dial. When you ask the modem to dial, do you hear
>'click' then hear the modem dialing?
>Technical specialist / Linuxant
>support at linuxant.com
>----- Original Message -----
>From: gab.cris at virgilio.it
>To: support at linuxant.com
>Sent: Tuesday, August 24, 2004 6:01 AM
>Hi Jonathan
>thank you for your kind help
>I inserted the line you suggested into /etc/mobprobe.conf.local
>and in effect now the module is not present into lsmod output list 
>There seems not to be any error now into hsfdiag.txt file; the handshakin=
>of modem seems now ok:
>after I launch ATDTXXXXXXX
>it answers "Waiting for carrier" (it didn't before!!)
>but after 20 secs it returns "No carrier" again......
>It happens also with linemode  terminal (minicom)
>There seems to be no tone into line... though the volume of speaker is
>im afraid....
>I also put initialization string I picked from windows modem connection
>log file
>(i.e. :  AT&FE0V1S0=3D0&C1&D2+MR=3D2;+DR=3D1;+ER=3D1:W2
> and ATS7=3D60M1+ES=3D3,0,2;+DS=3D3;+IFC=3D2,2;X4
>it gave me OK... into windows it is sufficient.. perhaps the problem is
>not his one)
>I checked into *.cty file into XP system and I noticed that settings for
>were a little bit different from settings into linux_via_smartmc.inf;
>is it the file hsf modem use? now, into Suse distribution, I cannot find
>it.... into mandrake
>It seems to me this was the file hsf used...
>maybe I have to copy settings from fsm118e.cty somewhere, now.
>I also found old hsfdiag.txt from mandrake 10.0 system;
>im attaching the current  hsfdiag.txt, the old (mandrake) hsfdiag.txt
>and the fsm118e.cty from my XP system... hope it helps....
>thanks again for your help.... as soon as i reached my connection by this=
>i'm downloading full version!!! i promise :)
>Bye for now... 
>>-- Messaggio originale --
>>Date: Mon, 23 Aug 2004 15:06:38 +0000
>>From: "Linuxant support (Jonathan)" <support at linuxant.com>
>>To: gab.cris at virgilio.it
>>Subject: Re: [hsflinux] Cannot open modem on Suse 9.1 - no such device
>>	address
>>Cc: hsflinux at lists.linuxant.com
>>Reply-To: support at linuxant.com
>>in the dump you have provided, we can see that you have the 'slamr' 
>>module in the output of the 'lsmod' command. This module often takes 
>>control of the modem, preventing the HSF driver to control your modem.
>>Since you are using SuSE 9.1, please add the following line in your 
>>'/etc/modprobe.conf.local' file :
>>install slamr /bin/true
>>Then, reboot your computer and try to use the modem.
>>For Mandrake 10, if you still want to use the modem driver on this 
>>distribution, please install the latest HSF driver package and then 
>>please send at support at linuxant.com a 'dumpdiag' that you can generate
>>with the 'hsfconfig --dumpdiag' command in a root shell.
>>Technical specialist / Linuxant
>>support at linuxant.com
>>gab.cris at virgilio.it wrote:
>>> Hello
>>> I've been trying to activate my modem but it doesn't work...
>>> I've got  a Fujitsu-Siemens C1020, with Suse9.1 installed.
>>> The installation procedure detected my modem identifying it by "intel
>>> - (AC97 Modem)"
>>> and some of the vendor parameters were correct, though it put "slamr"
>>> I executed scanModem and it seems to me the correct chipset is the Con=
>>> one.
>>> I tried to use modem but it give me "no answer" after dialing.
>>> I so download hsf driver for Suse (x86) - the 14400 bps free  version
>>> and installed it (rpm -i xxxx)
>>> i checked the lsmod output and I found various hsf xxx.
>>> but the modem still gives me "no answer" back. (after not checking 'wa=
>>> for dialton':
>>> should i leave this check, i got "no dialtone" instead)
>>> I tried "hsfconfig" but it ends with :"ERROR: no device detected by
>>> driver"
>>> I so tried by "modprobe ttySHSF0" and it sounds good;
>>> executing "dmesg" gives me back no errors at the end of files.
>>> I sincerely don't know how to proceed (the winmodem into XP runs ok)
>>> I previously had Mandrake 10.0 installed into my Fujitsu and I spent
>>> into trying to configure my modem, use all drivers i found into your
>>> (rpm, tar) compile, insert modules,
>>> changing initilization string of the modem.... I also copied the info
>>> windows driver file into linux_via_smartmc.inf but the modem always
>>> me "NO CARRIER"
>>> So i install Suse9.1 hoping to resolve but I see the same problem....
>>> I executed hsfconfig --dumpdiag and got the  output.
>>> Im now attaching the log file i obteined hoping it will be useful...
>>> please help :)
>>> thank you... in advance.... should you need any other info let me know=
>>> bye for now
>>> Gabriele

More information about the hsflinux mailing list