[hsflinux] hsflinux: Cannot open modem on Suse9.1: NO CARRIER [eid-20040825-d6c]

Linuxant support (Jonathan) support at linuxant.com
Thu Aug 26 11:19:22 EDT 2004


if you added the 'pci=noacpi' kernel boot parameter to the 
'/etc/lilo.conf' file, please make sure that you have run the 'lilo' 
command after you have made the modification to the file, then reboot 
your computer. Please read the 'lilo' manual page for more information.

It is posible that the problem is related to IRQ routing and the 
'pci=noapci' will disable ACPI for IRQ routing which is required on some 
machines. This is very unlikely that you have a conflict with the 
ethernet card.


Technical specialist / Linuxant
support at linuxant.com

gab.cris at virgilio.it wrote:
> Hi again Jonathan
> The modem still doesn't respond... always "NO CARRIER"
> Little summary below:
> - I download hsfmodem-6.03.00lnxt04072900full_k2.6.4_52_default-1suse.i586.rpm
>   module and install it on my Suse 91 OS
> - I configure with hsconfig, leaving default values when asked and writing
> "ITALY" at the end
> - I tried to dial with the string :
> 	AT&FE0V1S0=0&C1&D2+MR=2;+DR=1;+ER=1;W2
>         ATS7=60M1+ES=3,0,2;+DS=3;+IFC=2,2;X4
>   like the Modem.txt log file of WinXP modem activities said
> - I tried with AT &F X1, besides that values.
> - I put "pci=noacpi" into lilo.conf
> - I modified OEM_FLAGS with values you said.
> my modem initializes, accepts the string , but does not compose the number..
> in any way....
> may the plugged in ethernet cable conflicts?
> may some IRQ be erroneous?
> I tried to install OS from scratch again, avoiding to load smartlink modem
> module as
> i was asked for at installation prompt (like it find the modem to be smartlink)
> This time i don't have slamr module loaded, but when I first tried to configure
> modem (It gave me the correct model: "Fujitsu Intel 537 [AC97 Modem]", like
> into
> WinXP system I have) I was asked, by default, to add smartlink driver (present
> into distribution CD) I answer "no" and I had to configure a generic modem,
> with modem device "/dev/modem".
> Was it correct.
> The final results are the same... all is ok but when it tried to dial it
> cannot...
> Let me know if there are some other ways.... perhaps another driver....
> or if you need 
> other info
> When I had Mandrake 9.0 (with kernel 2.4.x) into my system, I used Conexant
> driver and the modem worked.... now I cannot see any light... tell me if
> I have any hope besides to go back  to Mandrake 9...
> Thanks for you kind help....
> bye for now
> Gabriele

More information about the hsflinux mailing list