[hsflinux] Problems to install in Debian

Linuxant support (Jonathan) support at linuxant.com
Thu Oct 7 11:37:41 EDT 2004


the problem is that the modprobe tool is unable to install the modules 
with the 'modprobe /dev/ttySHSF' command in a root shell. However, the 
proper 'install /dev/ttySHSF ...' lines are present in the 
'/etc/modprobe.conf' and the '/etc/modprobe.d/hsf' files but they are 
not found by the 'modprobe' tool for an unknown reason.

Please try with different versions of the 'module-init-tools' package to 
see if there is a difference.


Technical specialist / Linuxant
support at linuxant.com

Panayotis Katsaloulis wrote:
> I am using Debian Sid distribution and I am trying to install the hsf modem 
> drivers in debain.
> This problem is not package specific, since I tried both the DEB as also the 
> TAR.GZ package.
> The problem is that after the installation, when I run  I see this message:
> Conexant HSF softmodem driver, version 6.03.00lnxt04082400full
> If you need license keys, assistance or more information, please go to:
>         http://www.linuxant.com/
> When reporting a problem for the first time, please send
> us the file generated by "hsfconfig --dumpdiag".
> No pre-built modules for: Debian-3.1 linux-2.6.7 i686
> Trying to automatically build the driver modules...
> (this requires a C compiler and proper kernel sources to be installed)
> Where is the linux source build directory that matches your running kernel?
> [/lib/modules/2.6.7/build]
> Building modules for kernel 2.6.7, using source directory
> /lib/modules/2.6.7/build. Please wait...
> done.
> ERROR: hsf driver not active
> Since it is advisable to send the hsfdiag.txt, I have uploaded it to
> http://hellfire.di.uoa.gr/hsfdiag.txt
> If I try to manually modprobe some hsf* modules and then start again the 
> procedule is successfull.
> So it seems to be a problem with the module configuration.
> How can automatically solve this situation?

More information about the hsflinux mailing list