[hsflinux] doesn't detect RING

Nerijus Baliunas nerijus at users.sourceforge.net
Wed Oct 20 02:07:46 EDT 2004

On Thu, 14 Oct 2004 09:32:13 +0000 "Linuxant support (Jonathan)" <support at linuxant.com> wrote:

> Nerijus Baliunas wrote:
> > 
> > I have U.S. Robotics V.92 Fax Host Int PCI internal modem and
> > it works with hsf driver (040824), I can dial, etc. The problem is,
> > it does not detect the ring. When I am in minicom and dial to
> > this modem, it does not write 'RING'. If I set ats0=2, it does not
> > answer after 2nd ring. It answers only if I enter ATA manually.

> please try with this initialization string :
> AT &F

Tried of course ;-)

> You should also make sure that you have selected the right country when 
> you installed the modem driver. You can obtain the currently set country 
> in the output of the 'hsfconfig --info' command in a root shell and you 
> can change this setting with the 'hsfconfig --country' command in a root 
> shell.

Tried a few, didn't help.

> If you require more assistance, please send at support at linuxant.com the 
> output of 'dumpdiag'. Type the following in a root shell:

IMHO there's really no need, as modem otherwise works, and it answers
if I enter ATA. Can anyone confirm that a modem (any) using HSF driver
writes RING when it detects ring? I suspect a line problem here.
Anyway, I replaced the modem, so it's not that important for me anymore.


More information about the hsflinux mailing list