[hsflinux] can't install hsfmoden in kernel 2.6.9

Linuxant support (Jonathan) support at linuxant.com
Mon Nov 8 14:57:48 EST 2004


please send at support at linuxant.com the output of the following commands 
entered in a root shell, it will help us solve the problem :

dmesg -c > /dev/null   # This command will produce no output
modprobe hsfmc97ich
hsfconfig -i

What is the error message you obtain when you try to dial after you have 
tried to manually load the HSF modules?


Technical specialist / Linuxant
support at linuxant.com

Chao-Cheng Wu wrote:
> Hi,
> I downgrade 'module-init-tools' to version 3.1pre5-7, but I still got the same 
> error message.
> Another strange thing is the module, 'hsfmc97ich', which was compiled from the 
> complete kernel source (not just from kernel header) can be loaded manually 
> without that error message, but 'hsfconfig' still told me it can't load that 
> module. If I try to load the whole modules manually, it still can't transmit 
> and receive packages after I dial up....
> I attached my system detail again...
> Do you have any advanced suggestion?
> Sincerely,
> Chao-Cheng WU
> On Saturday 06 November 2004 05:11 am, Linuxant support (Jonathan) wrote:
>>it is possible that this is a problem related to the 'module-init-tools'
>>package. Please downgrade to 'module-init-toolsmodule-init-tools' version 
> 3.1pre5 (you
>>are currently using 3.1pre6) and please report if it worked or not.
>>Technical specialist / Linuxant
>>support at linuxant.com
>>Chao-Cheng Wu wrote:
>>>My hsfmodem worked very well in my previous kernel, 2.6.7. But after I
>>>upgraded my kernel to 2.6.9, I can't install 6.03.00lnxt04082400full
>>>successfully. When I tried to load the hsfmc97ich module, it always show
>>>the following error messages:
>>>hsfsoar: Unknown symbol cleanup_module
>>>hsfsoar: Unknown symbol init_module
>>>hsfengine: Unknown symbol cleanup_module
>>>hsfengine: Unknown symbol init_module
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Read
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Create
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Control
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Close
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Write
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Open
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Monitor
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Configure
>>>hsfserial: Unknown symbol cnxthsf_ComCtrl_Destroy
>>>hsfmc97ich: Unknown symbol cnxthsf_cnxt_serial_add
>>>hsfmc97ich: Unknown symbol cnxthsf_cnxt_serial_remove
>>>hsfmc97ich: Unknown symbol cnxthsf_GetSOARLibInterface
>>>And my system detail is in the attached file.
>>>Does Anybody have some suggestions?
>>>Chao-Cheng Wu

More information about the hsflinux mailing list