[hsflinux] HSF - dial-in issue

mailing machsinger at yahoo.com
Thu Nov 25 06:14:03 EST 2004

I have a Fedora Core 2 system [Linux <node-name> 2.6.9-1.6_FC2 #1 Thu Nov 18 22:03:19 EST 2004 i686 athlon i386 GNU/Linux] with an OLITEC PCI 56K modem.
I have downloaded and succesfully installed the [hsfmodem-6.03.00lnxt04111500full_k2.6.9_1.6_FC2-1fdr.i686.rpm] package.
Since I have only one phone line, I hook the OLITEC modem to the phone line and my cell phone to the laptop.For the moment I am testing in terminal mode only.
Given the test environment, I can succesfully 
   1) dial-out from the Linux to a local ISP
   2) dial-out from the laptop (W2K Hypertrm) to the same local ISP

But when I dial-out from my laptop into the Linux box, after the [CONNECT 9600/RFP] I get only garbage and eventually the line dies.
On the Linux box my /etc/inittab has the line:
[S0:2345:respawn:/sbin/mgetty -s 9600 -n 2 -i /etc/motd.dialup -D ttySHSF0]
While I have the /etc/ppp/options.ttySHSF0 file and the proper entry in /etc/ppp/pap-secrets for when I will enable ppp, the AutPPP directive is commented out in /etc/mgetty+sendfax/login.config.
My /etc/mgetty+sendfax/mgetty.config contains
port ttySHSF0
#  debug 8
  data-only y
  speed 9600
  init-chat "" \d\d\d+++\d\d\dATQ0V1H0 OK ATS0=0Q0&D2&C1 OK
[NOTE - I've also tried without the init-chat line: it made no difference]

Anybody can suggest what I should look at?

Do you Yahoo!?
 The all-new My Yahoo! – What will yours do?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.linuxant.com/pipermail/hsflinux/attachments/20041125/018d9ee3/attachment.htm

More information about the hsflinux mailing list