[hsflinux] Soundcard not working after installing hsfmodem driver

Linuxant support (Jonathan) support at linuxant.com
Mon Jan 10 13:45:17 EST 2005


Could you send at support at linuxant.com the output of 'dumpdiag' please? 
Type the following in a root shell:

hsfconfig --dumpdiag

Just send us the generated file located in /tmp ('hsfdiag.txt').
It'll help us solve the problem.

The disabled modules are for modems and not for a sound card.

Please try to remove the installed HSF driver package and reboot your 
machine to see if the sound card now works or not.


Technical specialist / Linuxant
support at linuxant.com

Gianni wrote:
> Hello,
> I installed the HSF Modem driver from Linuxant (full with license) 
> hsfmodem-
> on my laptop running Mandrakelinux 10.1 (kernel version . The 
> first time I connected to the Internet immediately after installing the 
> softmodem driver it all worked fine and it was possible to hear the modem 
> tones via the soundcard. 
> After rebooting the system the modem is still working but the soundcard is not 
> found anymore during boot process. This is the Error message: 
> [root/usr/sbin/alsactl: load_state:1139:@presario Linux] soundcard not found
> During the installation of the hsf driver I noticed the following warnings:
> Note: kernel module snd-intel8x0m overridden by hsfmc97ich hsfmc97sis
> Note: kernel module snd-atiixp-modem overridden by hsfmc97ati
> So I tried to enable the original kernel modules replaced by the hsfmodem 
> driver by typing on a root konsole
> modprobe  snd-intel8x0m
> and
> modprobe snd-atiixp-modem
> but nothing has changed. I'm a newbie as far as kernel configuration is 
> concerned.. maybe I typed the wrong commands.
> thanks for your help. 
> Gianni
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list