[hsflinux] Cannot get hsf driver to work, close, but no go!

Dave inssomniak at mountaincable.net
Mon Mar 7 01:27:37 EST 2005

Gentoo 2-6.10-r6 kernel AMD64

The driver compiles fine, but wont load correctly  and hsfconfig keeps 
telling me its not detected.  the auto-installer detects it as an HSF 
conexant modem PCI ID:  14F1:2013  ,.  Here is my dmesg, etc

ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 18 (level, low) -> IRQ 209
cnxthsf_cnxt_serial_add: ComCtrlOpen failed (1)
hsfpcibasic2: probe of 0000:00:0a.0 failed with error -5
usbcore: registered new driver hsfusbcd2

Module                  Size  Used by
hsfusbcd2              73328  0
hsfmc97sis             63976  0
hsfmc97ati             61848  0
hsfmc97ali             68960  0
hsfmc97via             65008  0
hsfmc97ich             67496  0
hsfpcibasic2           71720  0
hsfserial              21924  7 
hsfengine            1626624  1 hsfserial
hsfosspec              93712  9 
hsfsoar                64808  7 
nvidia               4049244  12


No pre-built modules for: unknown-unknown linux-2.6.10-gentoo-r6 x86_64

Trying to automatically build the driver modules...
(this requires a C compiler and proper kernel sources to be installed)

Where is the linux source build directory that matches your running kernel?

Building modules for kernel 2.6.10-gentoo-r6, using source directory
/lib/modules/2.6.10-gentoo-r6/build. Please wait...
error: 'kernel.modprobe' is an unknown key

ERROR: no device detected by hsf driver

More information about the hsflinux mailing list