[hsflinux] FULL Version & SuSE 9.3 problem

Fau Marz faumarz at libero.it
Fri May 13 10:21:17 EDT 2005

I am a registered user for both LinuxANT HSF Modem drivers and driverloader 

I'm getting a problem with HSF Modem driver and SuSE Linux 9.3.

In the past I've used SuSE 9.2 with the modem driver and I had no problems.

Now I've installed SuSE 9.3 on the same PC (installed from scratch in dual 
boot with the old SUSE 9.2) and after re-installing the modem driver (using 
cnxtinstall.run) I find that trying to connect with kinternet or cinternet 
make the system hard-crash: it hangs all the computer and you can do nothing 
else than turn the power off.

If I try the drivers in the "free" configuration (max 14400baud, no fax) the 
connection works properly; after registering the drivers with my license key 
to the full version, the modems hangs up the entire system when trying to 
connect. The modem is configured with YAST, and I've tried first at 57600baud, 
then I reduced the speed at 14400 (as in the free license) but the result is 
the same: after registering the license key the modem makes the system crash.
I've tried also to change country (ITALY or USA) without any result.
I've tried both the precompiled package and the generic package, with the same 

My computer is a Fujitsu-Siemens AMILO V7010, with Conexant AC'97 Modem

This is the output for hsfconfig --info:
Note: kernel module snd-via82xx-modem overridden by hsfmc97via
Note: kernel module snd-intel8x0m overridden by hsfmc97ich hsfmc97sis
Note: kernel module slamr overridden by hsfmc97ich hsfmc97sis hsfmc97via 
Note: kernel module snd-atiixp-modem overridden by hsfmc97ati

Current parameters: ("hsfconfig --info")

Config for modem unit 0: /dev/ttySHSF0
        Device instance: 0-PCI-1002:434d-1734:1062
        HW revision    : CXT30
        HW profile name: hsfmc97ati
        Registration ID: D556-C251-8EC8
        License owner  : faumarz at libero.it
        License key    : 16-4E-31-5A-45-5D
        License status : OK
        Current region : ITALY (T.35 code: 0059)

If you need more info, please ask me.

May someone help me having my full version drivers working?

Thank you,

Fausto Marzoli


More information about the hsflinux mailing list