[hsflinux] error:hsf driver not active NEED HELP

Brian Springstead bsprings at bestweb.net
Mon Sep 5 22:06:11 EDT 2005

Of course I am having problems getting my modem to work.  I downloaded 
hsfmodem-, upacked
it and did a "make install".  I got this package because the others 
listed didn't seem to fit my system.  It seemed to install ok, then it 
asked me to run "hsfconfig".  It asked for a location and I accepted the 
default which looked right (/lib/modules/2.6.11-1.1369_FC4) I got a done 
message, but then I got "ERROR: hsf driver not active".  I read the FAQ 
(no help, this problem isn't even mentioned).  I searched the archives 
and found a few other people with this same problem but I didn't find a 
solution that worked for me.  I got the same results with a web search.  
I used "hsfconfig --dumpdiag" but the file it produced was nearly 250k, 
so I didn't upload it.

I tried using modprobe to install these modules but I got:
WARNING: Error inserting hsfosspec 
(/lib/modules/2.6.11-1.1369_FC4/exta/hsfosspec.ko): Unknown symbol in 
module or unknown parameter (see dmesg)
            ...couple more similar messages and then...
FATAL: similar stuff as above

An "lspci" gives me:
02:01.0 Communication controller Conexant: Unknown device 2f20

I used an application called "list_modem" (in Windows) I found somewhere 
on the web on the same machine and it gave me the follow information:
type: HSF
vendor id: 14F1
device id: 2F20
subvendor id: 14F1
subdevice id: 2000
revision: 00

Machine information:
emachines T6212
AMD64 Athlon 3200+
512m RAM
160G HD
Fedora Core 4
kernel: standard FC4 install 2.6.11-1.1369_FC4

I am open to suggestions, since I am not sure what is the cause of the 
problem.  Thanks in advance.

More information about the hsflinux mailing list