[hsflinux] problems after kernel upgrade

Linuxant support (Jonathan) support at linuxant.com
Tue Sep 27 11:10:43 EDT 2005


we can see the following error message in your 'dmesg':

hsfusbcd2: version magic ' preempt PENTIUM4 gcc-3.3' should be 
' preempt PENTIUMM gcc-3.3'

(Notice the difference between PENTIUM4 and PENTIUMM).

The modules were compiled with kernel headers that do not correspond to 
your running kernel. Try recompiling the modules with 'hsfconfig 
--kernel' and ensure that the source tree used corresponds to your 
running kernel.

Alternatively you may try to boot or install another kernel and its 
corresponding source/header files.


Technical specialist / Linuxant
support at linuxant.com

daskalomarkoulakis wrote:
> Hallo. I recently installed debian Sarge on my acer 4100 laptop and used 
> the hsfmodem_7.18.00.05full_i386.deb to test the modem. Shortly after 
> this I upgraded my kernel to  I uninstalled the hsfmodem 
> package(modem was not working after the upgrade) and tried to install 
> the hsfmodem_7.18.00.06full_i386.deb
> And then I stuck to the usual message...
> Building modules for kernel, using source directory
> /lib/modules/ Please wait...
> done.
> ERROR: hsf driver not active
> dpkg: error processing hsfmodem (--install):
> subprocess post-installation script returned error exit status 1
> Errors were encountered while processing:
> hsfmodem
> I send you the text file generated
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list