[hsflinux] kppp reporting 'unable to open modem'

Guerreiro da Luz g.da.luz at gmail.com
Mon Dec 12 22:55:15 EST 2005

Got Thinkpad R51 machine with Conexant HSF softmodem
(PCI-8086:24c6-1014:055a).  So I downloaded free version of Linuxant
HSF modem driver and installed it along with my kernel (stock, my machine is Slackware 10.2 btw).  Tried driver with
minicom and it works great, so I'm certainly going to order full
license.  However, I do have small problem with kppp dialer - it keeps
reporting 'unable to open modem' when I try dialing.  I do have
/dev/modem link to /dev/ttySHSF0.  I tried to use wvdial and it works
fine.  I tried set to modem initialization sequence in kppp to same
sequence minicom or wvdial are using, but same error still there. 
Weirdest of all, if I launch either minicom or wvdial once and then
exit and try kppp again, it works perfectly.  So it's not that big
deal, but still I would like to have it working without this "hack" -
maybe someone on this list could offer some advice regarding how to
track what minicom or wvdial are doing that kppp is not or anything
else to try?


More information about the hsflinux mailing list