[hsflinux] Re: kppp reporting 'unable to open modem'

Linuxant support (Jonathan) support at linuxant.com
Wed Dec 14 10:48:34 EST 2005


the source of the problem could be either kppp, the kernel of the HSF 
modem driver. You are the first user which have reported this issue and 
we will investigate if other users report it as well. If this is a bug 
in the HSF modem driver, it will be fixed in a future release of the driver.


Technical specialist / Linuxant
support at linuxant.com

Guerreiro da Luz wrote:
> On 12/13/05, Linuxant support (Jonathan) <support at linuxant.com> wrote:
>>the messages found in your 'dmesg' are generated when the HSF modem
>>driver modules are inserted into the kernel and they are not affected by
>>the dialing program used.
>>To try to tack down the problem with 'kppp' you could try to use an
>>utility such as 'strace' to see what system calls are called by 'kppp'
>>and compare the trace with a working dialing software to see what is the
>>exact source of the problem. Alternatively, you could build 'kppp' from
>>sources with possibility more debugging output which might help to track
>>down this problem.
>>Technical specialist / Linuxant
>>support at linuxant.com
> Jonathan,
> Thanks for hints.  I was able to find analyzing kppp source that the
> problem occurs when calling tcsendbreak() syscall - it should send a
> stream of zeroes to modem for 0.5s or so and there is a timeout in
> kppp source around it to check if it will hang after 2s and report
> above error if it does.  So this is what happens - tcsendbreak() for
> some reason hangs if minicom or wvdial not launched before kppp.  Now,
> even if I code around this, compiling kppp from source is real pain
> (whole kdenetwork package should be compiled actually), thus I think
> I'm rather going to spend some more time to find workaround.  Since I
> have my license delivered now - are more questions regarding above
> appropriate to Linuxant support e-mail address or your position would
> be that since driver is definitely working (as confirmed by minicom
> and wvdial) then these kppp woes are not your business?
> Regards.
>>Guerrero da Luz wrote:
>>>On 12/12/05, Guerreiro da Luz <g.da.luz at gmail.com> wrote:
>>>>Got Thinkpad R51 machine with Conexant HSF softmodem
>>>>(PCI-8086:24c6-1014:055a).  So I downloaded free version of Linuxant
>>>>HSF modem driver and installed it along with my kernel (stock
>>>>, my machine is Slackware 10.2 btw).  Tried driver with
>>>>minicom and it works great, so I'm certainly going to order full
>>>>license.  However, I do have small problem with kppp dialer - it keeps
>>>>reporting 'unable to open modem' when I try dialing.  I do have
>>>>/dev/modem link to /dev/ttySHSF0.  I tried to use wvdial and it works
>>>>fine.  I tried set to modem initialization sequence in kppp to same
>>>>sequence minicom or wvdial are using, but same error still there.
>>>>Weirdest of all, if I launch either minicom or wvdial once and then
>>>>exit and try kppp again, it works perfectly.  So it's not that big
>>>>deal, but still I would like to have it working without this "hack" -
>>>>maybe someone on this list could offer some advice regarding how to
>>>>track what minicom or wvdial are doing that kppp is not or anything
>>>>else to try?
>>>After sending previous message, I realized two previous threads on
>>>this list had also to do with kppp problems on Thinkpads (it would be
>>>really good to have search capability available directly on the Web
>>>for this list) and I found some hints.  I tried to run "hsfconfig
>>>--dumpdiag" before and after launching minicom (ie. before and after
>>>being able to use kppp properly) and here is the difference (what
>>>follows appears only after launching minicom):
>>>< usbcore: deregistering driver hsfusbcd2
>>>< PCI: Found IRQ 11 for device 0000:00:1f.6
>>>< PCI: Sharing IRQ 11 with 0000:00:1f.3
>>>< PCI: Sharing IRQ 11 with 0000:00:1f.5
>>>< PCI: Setting latency timer of device 0000:00:1f.6 to 64
>>>< ttySHSF0 at I/O 0x2400 (irq = 11) is a Conexant HSF softmodem (PCI-8086:24c6-1
>>>< usbcore: registered new driver hsfusbcd2
>>>So I guess what kppp is missing is some kind of executing setserial
>>>equivalent for HSF modem, in order to set IRQ and I/O port; but HSF
>>>modems FAQ states it is not possible to use setserial on
>>>/dev/ttySHSF*.  Any hint?
>>>hsflinux mailing list
>>>hsflinux at lists.linuxant.com
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list