[hsflinux] Re: kppp reporting 'unable to open modem'

Linuxant support (Jonathan) support at linuxant.com
Thu Dec 15 11:21:22 EST 2005


we have experienced similar problems with the 2.6.14-rcX kernels but 
these problems were fixed on our development systems with the final 
2.6.14 kernel. We will keep our eyes open on this issue and provide, if 
we are able to reproduce the problem, a better patch/workaround for the 


Technical specialist / Linuxant
support at linuxant.com

Guerreiro da Luz wrote:
> On 12/14/05, Nate Bargmann <n0nb at networksplus.net> wrote:
>>* Guerreiro da Luz <g.da.luz at gmail.com> [2005 Dec 14 11:41 -0600]:
>>>On 12/14/05, Linuxant support (Jonathan) <support at linuxant.com> wrote:
>>>>the source of the problem could be either kppp, the kernel of the HSF
>>>>modem driver. You are the first user which have reported this issue and
>>>>we will investigate if other users report it as well. If this is a bug
>>>>in the HSF modem driver, it will be fixed in a future release of the driver.
>>>I just tried deleting 2.6.14 workaround in serial_cnxt.c and
>>>recompiling, but to no avail.
>>Okay, hopefully I can shed a bit more light based on experiments I did
>>I followed Guerreiro's advice and was sure to exit minicom with the
>>Ctl-a q key sequence whereupon kppp worked wonderfully.  I might add
>>that the hsfmodem gives a far better throughput with compression than
>>the 56k PCMCIA modem I was using--good work!
>>Now to troubleshoot this further I rebooted in my KNOPPIX 4.0.2
>>partition and installed the hsfmodem binary package for its kernel
>>2.6.12 and kppp worked flawlessly and speedily with my license key
>>applied.  This confirms my assertion that this package worked about six
>>weeks back with a Debian 2.6.12 kernel.
>>Back to Sid with 2.6.14 and a bit more experimentation.  At first we
>>(co-worker and me) thought it might be an initialization string issue,
>>but it wasn't.  In kppp one can search for the modem and with the
>>default of hardware flow control, kppp reports modem not responding.  I
>>next tried the modem search with flow control set to None and it found
>>the hsfmodem devices.  I tried connecting to my ISP in this fashion and
>>it didn't work.  So, I went to the third option and set the flow
>>control to soft (XON/XOFF) and now the modem is found, configured, and
>>a connection to the ISP works well as in KNOPPIX.
>>Guerreiro, can you try setting your kppp's flow control to soft and see
>>if that works?  Make sure to reboot so the hsfmodem is in its default
> Nate,
> Great work - with software flow control, it works for me too (with
> vanilla kernel and without anything changed in
> serial_cnxt.c).
> Regards.
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list