[hsflinux] HSF modem works but box no more powers down

R.f.P tucoolat at free.fr
Mon Dec 26 11:45:39 EST 2005

I installed HSF driver on my linux 2.6.3-1-i386 ATX box 
(a Toshiba 1400 satellite with an internal AMR winmodem hence I bought 
the Olitec USB V92 Ready modem). Now it works fine ( I just tried 
dialing, not fax ) but when halting or rebooting the system, it hangs 
with the message : "drivers/usb/core/usb.c : deregistering hsfusbcd2". 
Nothing to do but to shut down manually. hsfconfig --dumpdiag aborts 
with "+hfstop", but with --noprobe I get a 113K file ( not included but 
available on request ).
    I tried hsfstop or hsfconfig --rcstop, followed by halt or reboot : 
it hangs with the above message. dmesg says : hsfsoar : no version for 
"struct_module" found ; kernel tainted and similarly for hsfengine. ACPI 
is enabled and APM disabled but acpi=off on boot does not solve the 
problem ( may be was it necessary to enable simultaneously APM ? ).
    Could it be that hsfstop is run too early ? Not relevant as I tried 
putting a line "sleep 10" in rchsf script, with no success. Idem with 20 
in place of 10 seconds sleeping.
    I discovered in /proc/devices that hsfusbcd2 did not registered 
itself, so how could it be subsequently " deregistered " ? This might 
explain why it hangs, isnt'it ? But I don't know how to remedy. Somebody 
could please help me ?

More information about the hsflinux mailing list