[hsflinux] "No carrier" error.

Francois Beerten linuxant.20.fb at spamgourmet.com
Sat Dec 31 16:04:12 EST 2005

Linuxant support (Jonathan) wrote:

> Please make sure that the right country is selected with the 
> 'hsfconfig --country' command in a root shell. You could try with 
> different countries as well, one of them might solve the problem.

We checked that. It's was set to Belgium where we live. When it worked 
on the older machine it was set to Belgium too. We also tried with many 
other countries without any positive result.

> Please also try with the 'AT &F X1' init. string to see if there is a 
> difference.

We tried it too without success. It was one of the few things, we found 
on the mailing lists.

> If you require more assistance, please tell us what was the version of 
> the HSF modem driver which was working fine on SuSE 8.0.

It was on Mandrake 8.0 instead of Suse 8.0. We used the hsf driver 
available on your website for mandrake 8 with the default kernel.

We are trying with the current version hsfmodem- We got the 
driver to work on the old PC with hsfmodem- Unfortunatly, we 
dont have the old PC anymore.

> Since you have moved the modem to a new machine, you could try under 
> Windows XP on the new machine just to make sure that it works well.

The modem works under Windows on the new machine.

Thanks for your help,

Francois Beerten.

> Francois Beerten wrote:
>> Hi,
>> We are trying to get a Conexant HSF based modem to work under Linux. 
>> The linuxant driver exposes a device and kppp manages to connect to 
>> it. But dailing a number does not work. We hear the dail tone but 
>> nothing else. After a long period the modem aborts and reports "No 
>> carrier".
>> The modem is a "Conexant Puresoft V90 PCI". The system has Mandrake 
>> 10.1 community with the default kernel. The hfsdiag.txt is attached 
>> to this email. We tried most tips we found in the FAQ or on the 
>> mailing list.
>> The modem works well in Windows on the same PC. The modem worked with 
>> linuxant on an old PC and Mandrake 8.0.
>> Thanks for your help,
>> Francois Beerten.

More information about the hsflinux mailing list