[hsflinux] no device detected by hsf driver with a HDA Modem

Linuxant support (Jonathan) support at linuxant.com
Mon Mar 27 17:25:26 EST 2006


the source of the problem seems to be from that command:

+ modprobe -v /dev/ttySHSF
install /sbin/modprobe hsfpcibasic2; /sbin/modprobe hsfmc97ich; 
/sbin/modprobe hsfmc97via; /sbin/modprobe hsfmc97ali; /sbin/modprobe 
hsfmc97ati; /sbin/modpr
obe hsfmc97sis; [ -e /lib/modules/`uname -r`/extra/hsfusbcd2.ko ] && 
/sbin/modprobe hsfusbcd2; /sbin/modprobe snd_hda_intel; /bin/true
insmod /lib/modules/2.6.16-gentoo/extra/hsfsoar.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfosspec.ko dcpmajor=243 
insmod /lib/modules/2.6.16-gentoo/extra/hsfengine.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfserial.ko serialmajor=240
insmod /lib/modules/2.6.16-gentoo/extra/hsfpcibasic2.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfmc97ich.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfmc97via.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfmc97ali.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfmc97ati.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfmc97sis.ko
insmod /lib/modules/2.6.16-gentoo/extra/hsfusbcd2.ko
insmod /lib/modules/2.6.16-gentoo/kernel/sound/pci/hda/snd-hda-codec.ko
insmod /lib/modules/2.6.16-gentoo/kernel/sound/pci/hda/snd-hda-intel.ko

It seems that the original snd-hda-codec and snd-hda-intel modules (in 
the /lib/modules/2.6.16-gentoo/kernel/sound/pci/hda/ directory) are 
loaded instead of the replacements provided by the HSF modem driver (in 
the /lib/modules/2.6.16-gentoo/extra/ directory).

Normally, the hsfconfig script should disable the modules in the 
/lib/modules/2.6.16-gentoo/kernel/sound/pci/hda directory so the 
expected modules are loaded. For an unknown reason, it didn't work on 
your system. Please try to run the following commands in a root shell, 
this will probably fix the problem:

cd /lib/modules/2.6.16-gentoo/kernel/sound/pci/hda/
mv snd-hda-codec.ko snd-hda-codec.ko.REPLACED
mv snd-hda-intel.ko snd-hda-intel.ko.REPLACED
hsfconfig -i

It is also possible that you will have to reboot your machine after 
these steps if the snd-hda-codec and snd-hda-intel modules can't be 
removed from the kernel for some reason.


Technical specialist / Linuxant
support at linuxant.com

Paulo Matias wrote:
> My notebook is an Acer TravelMate 4062WLMi with a Conexant HSF Modem
> plugged into codec#1 at HDA Bus. I'm using Gentoo and HSF driver was
> installed using ACCEPT_KEYWORDS="~x86" emerge hsfmodem.
> I've tried to install HSF in Linux 2.6.15, in Linux 2.6.16 and in
> Linux 2.6.16 + ALSA-CVS and got the same error:
> # hsfconfig
> Conexant HSF softmodem driver, version
> If you need license keys, assistance or more information, please go to:
>        http://www.linuxant.com/
> When reporting a problem for the first time, please send
> us the file generated by "hsfconfig --dumpdiag".
> Warning: existing driver modules found under:
>        /lib/modules/2.6.16-gentoo/
> Would you like to keep using them? [no] yes
> ERROR: no device detected by hsf driver - HDA modems may require reboot
> Tried to reboot, re-reboot, and nothing...
> How can I fix it? Please, help me as fast as possible, because I will
> need this modem working at sunday now.
> Thanks a lot,
> Paulo Matias
> ------------------------------------------------------------------------
> _______________________________________________
> hsflinux mailing list
> hsflinux at lists.linuxant.com
> https://www.linuxant.com/mailman/listinfo/hsflinux

More information about the hsflinux mailing list